Write Protection removal

Asked by Rick Miller on 2016-05-15

Evening:

   I should have come here first. I need to remove the write protection that Win7, somehow, installed on my pendrive. EVERYTHING I could find/try pertaining to Win7 has failed to remove the protection. Even tried 3 different software programs, and none could "write to" the disc or overwrite the protection. Even tried to repartition and guess what..."Could not perform task for disc is write protected"(Win7). Whatever Win7 did, it seems irreversible by Win7 standards. Now, I'm sure it's Ubuntu/Linux to the rescue!!! Has anyone had to do this (write protection removal) and would you kindly share your procedure. BTW "actionparsnip"... seriously??? A strong magnet?

      Lexar 16Gb pendrive formatted in FAT32 (6+ gigs unused)

Thanx:
Rick

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu kubuntu-meta Edit question
Assignee:
No assignee Edit question
Last query:
2016-05-17
Last reply:
2016-05-20

Have you ran an fsck on the USB partition?
When you are finished with the USB storage do you use the safe remove feature in the OS before physically unplugging it?

Rick Miller (69rixter) said : #2

actionparsnip:

   Andrew, good to hear from you again. #1. No, haven't run any Linux/Ubuntu operations as yet. I will today for my friend is lending his machine. #2. I always use the 'disk removal" operation before removing a USB stick! Hopefully, today I'll use friend's machine and get this aggravating issue solved. BTW... a strong magnet? care to elaborate?

Rick

If you are happy to lose the data on the drive then yes a magnet will reset it. I also suggest you remove the existing partition then recreate it and a long format. You could also use dban in Linux to blank the device.

Good to hear you use the safe remove feature. Lots of people don't then are surprised when they get issues

Rick Miller (69rixter) said : #4

actionparsnip:

   Andrew...tried to re-partition using Ubuntu, wouldn't work it said"Unable to open- drive was write protected"???? Didn't think Linux/Ubuntu recognized that? So, tried to delete file I thought was culprit and it "said" it deleted it...until I opened the drive and there it was? This is unbelievable. I really thought Linux would do it. Any ideas/suggestions? Oh, used Gparted for partition and fdisk for deletion.
THANX:
Rick

Does the device have a hardware based switch to write protect it?

Rick Miller (69rixter) said : #6

Andrew:

   LOL LOL I see you think I'm a complete idiot. NO, there is No physical switch!! Could there be an internal "switch"(?) that I must deactivate? In other words...what "parameters" are within the drive itself to activate/deactivate the write protection? And.. even if I were to "use" a strong magnate, wouldn't that wipe the MBR as well? OK, should it wipe "everything". isn't there a way to re-establish a working MBR and from there everything else?(format)
Still Baffled:
Rick

I don't think anyone is an idiot unless they demonstrate it. I cover all bases and eventually the next step is clear. Some devices have hard switches to make them write protected.

Can you help with this problem?

Provide an answer of your own, or ask Rick Miller for more information if necessary.

To post a message you must log in.