How to avoid akonaditray to start?

Asked by Uqbar on 2012-01-30

I have completely disable the akonadi-related functions, daemons and the likes.
The only remnant is the akonaditray.
I want it not to be spawned at all.
How to?
TIA

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu kubuntu-meta Edit question
Assignee:
No assignee Edit question
Solved by:
Uqbar
Solved:
2012-01-30
Last query:
2012-01-30
Last reply:
2012-01-30

Check in your KDE startup apps, as well as in ~/.kde/Autorun

Uqbar (uqbar) said : #2

There's nothing anywhere.
And, by the way, it's Autostart not Autorun.
At least in KDE v4.8.0.

My bad, not used kde in a while. If you kill the process does it stay dead?

Uqbar (uqbar) said : #4

Yes, it dies of course. But will restart at the next KDE login.

You could add run:

kate ~/.kde/Autostart/killakonaditray

and add these 2 lines:

#!/bin/bash
sleep 5
killall akonaditray

close kate and run:

chmod +x ~/.kde/Autostart/killakonaditray

now when you log in the process will be killed automagically for you. This is a work around unitil you can find something more graceful. I assume the process is called akonaditray. You can check with:

ps -ef | grep akon | grep -v grep

or if you already know the process name then change it, you get the idea.

Uqbar (uqbar) said : #6

This is a workaround: somewhere akonaditray gets started and I kill it later.
The solution I'm looking for is ti disable akonaditray completely!

Like I said.... You have this "unitil you can find something more graceful".....

Maybe others can advise differently but that will work.

Uqbar (uqbar) said : #8

https://bugs.launchpad.net/ubuntu/+source/kdepim-runtime/+bug/868970/comments/11

This is a solution. It's not through any KDE GUI, though.