Wired internet connection doesn't work after Kubuntu 11.10 upgrade

Asked by Vojko Jazbinsek on 2011-10-14

After the Kubuntu 11.10 there is no wired (LAN) internet connection.

Before the upgrade everythig worked fine.

In the system settings I opened Internet connection, but I don't know what to do.

I have the folowing options:

Obtain an IP address automatically
Obtain DNS server automatically.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu kubuntu-meta Edit question
Assignee:
No assignee Edit question
Solved by:
Vojko Jazbinsek
Solved:
2011-10-17
Last query:
2011-10-17
Last reply:
2011-10-17

Can you give the output of:

sudo lshw -C network; lsb_release -a; uname -a

Thanks

Hera are the requeasted outputs:
sudo lshw -C network
 *-network DISABLED
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: 03
       serial: 6c:62:6d:69:65:0b
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:42 ioport:d800(size=256) memory:fbeff000-fbefffff memory:faffc000-faffffff memory:fbec0000-fbedffff

sudo lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric

sudo uname -a
Linux IMFM2857 2.6.35-22-generic-pae #35-Ubuntu SMP Sat Oct 16 22:16:51 UTC 2010 i686 i686 i386 GNU/Linux

Do you have a switch to enable / disable the connection. If so, press it

Benjamin Geiser (bgeiser8) said : #4

Could you please post the output of the following:

ls /etc/modprobe.d

Thank you.

Thanks a lot for suggestions. I've solved the problem in the following way:
First, I typed the following command
    sudo ifup eth0
and I got the answer:
    Ignoring unknown interface eth0=eth0

Then I asked the google, how to configure eth0 in Kubuntu and I followed instruction I found in
http://www.ubuntugeek.com/ubuntu-networking-configuration-using-command-line.html

I edit the file /etc/network/interfaces:
# The primary network interface - use DHCP to find our address
auto eth0
iface eth0 inet dhcp

Then I restart networking services using the following command
sudo /etc/init.d/networking restart

Network is now working without a problem.
However, I am a bit disappointing that I have to correct the file /etc/network/interfaces manually after upgrading to a new version of Kubuntu.
Note, that after upgrading, the /etc/network/interface file contained the following lines:
auto lo
iface lo inet loopback