Kubuntu 11.10 beta: systemsettings crashes when changing kde system language

Asked by Georg H. on 2011-10-01

I have Kubuntu 11.10 beta installed on my laptop.

If I try to change the system language the systemsetting application crashes every time.

me@zwerg:/dev$ systemsettings(6653): No language dictionaries for the language : "de"

systemsettings(6653)/python (plugin): Error while running factory function for Python plugin: "language-selector/language-selector.py"
Traceback (most recent call last):
  File "<string>", line 18, in kpythonpluginfactory_bridge
  File "/usr/share/kde4/apps/language-selector/language-selector.py", line 9, in CreatePlugin
    return QtLanguageSelector("/usr/share/language-selector/", component_data, widget_parent)
  File "/usr/lib/python2.7/dist-packages/LanguageSelector/qt/QtLanguageSelector.py", line 51, in __init__
    self.init()
  File "/usr/lib/python2.7/dist-packages/LanguageSelector/qt/QtLanguageSelector.py", line 75, in init
    self.updateLanguagesList()
  File "/usr/lib/python2.7/dist-packages/LanguageSelector/qt/QtLanguageSelector.py", line 187, in updateLanguagesList
    languageList = self._cache.getLanguageInformation()
  File "/usr/lib/python2.7/dist-packages/LanguageSelector/LangCache.py", line 376, in getLanguageInformation
    li = LanguageInformation(self, code, lang)
  File "/usr/lib/python2.7/dist-packages/LanguageSelector/LangCache.py", line 41, in __init__
    if 'gnome-' not in sys.argv[0]:
AttributeError: 'module' object has no attribute 'argv'
systemsettings(6653)/python (plugin): Failed to import module
systemsettings(6653)/kcontrol KCModuleLoader::loadModule: This module has no valid entry symbol at all. The reason could be that it's still using K_EXPORT_COMPONENT_FACTORY with a custom X-KDE-FactoryName which is not supported anymore
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id: 0x40000db

How can I fix this? Is this a Bug?

Thanks!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu kubuntu-meta Edit question
Assignee:
No assignee Edit question
Last query:
2011-10-01
Last reply:
2011-10-01

Sounds like one to me, I suggest you report it.You can start the ball rolling with:

ubuntu-bug systemsettings

Can you help with this problem?

Provide an answer of your own, or ask Georg H. for more information if necessary.

To post a message you must log in.