Why kubuntu-desktop depends on smbclient

Asked by Andrey Bondarenko on 2011-01-24

kubuntu-desktop version 1.205 depends on smbclient package, which in turn conflicts with samba4-clients. This makes impossible to use samba4-clients without removing kubuntu-desktop.

Is there any reasons not to replace smbclient dependency with dependency on samba-client (both smbclient and samba4-clients provides them).

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu kubuntu-meta Edit question
Assignee:
No assignee Edit question
Solved by:
Andrey Bondarenko
Solved:
2011-01-24
Last query:
2011-01-24
Last reply:
2011-01-24

Because a lot of Ubuntu users want access to network shares in Windows (and indeed in Linux sharing folders using the same technology). As far as I can tell it's so new users don't see what I would consider they would think "basic functionality" and I have heard small minded people throwing this around too much. The app is quite small in size but will appease a lot of users.

Just my opinion, you could log a bug if you feel it is excessive.

Andrey Bondarenko (abone) said : #2

I agree, that access to Windows shares might be considered as basic functionality. Both packages (smbclient, samba4-clients) provide command line tools smbclient for accessing them. The first one provides smbclient version 3.x, the second version 4.x. My question is not about dropping smbclient from dependencies, but about users choice.

But my question is now answered. It's my mistake. I didn't notice that samba4-clients provides smbclient not samba-client. So it is possible to use both versions.

I only use samba and not samba4 so couldn't comment here (ironically I am posting this as a comment rather than an answer so it will stay open). If you log a bug it may get attended.