[KCM] Driver Manager - Black screen after reboot

Asked by Georg Grabler on 2015-09-28

Well, that's an issue since the existence of the driver manager, basically, but it's time to open a bug report since I work around it for years now after every fresh install. It's very well documented in the archlinux wiki.

I don't understand the kcm plugin layout and how to debug it properly, but I may look into it anyway, but for people familiar with it it shouldn't be hard to fix.

Bug Description:
If there is an intel card installed (on board), and you have a seperate NVidia card by installing a proprietary driver, booting the kernel will result in:
- The kernel loading modeset due to the intel driver supporting it
- The NVidia card/driver not supporting it, resulting in a black screen. No, you never ever get out of the black screen.

Therefore, the option "nomodeset" for the kernel needs to be set (/etc/default/grub => GRUB_CMDLINE_LINUX_DEFAULT="nomodeset quiet splash"), and update-grub2 needs to be run.

I know this results in an uglier boot mode, but due to NVidia not supporting modeset, there is no option if the proprietary driver is installed than to choose this option! Otherwhise, users end up with a disfunctional system.

100 % reproducable on 3 PCs I have.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu kubuntu-driver-manager Edit question
Assignee:
No assignee Edit question
Last query:
2015-09-28
Last reply:
2015-09-29

I suggest you report a bug.

Can you help with this problem?

Provide an answer of your own, or ask Georg Grabler for more information if necessary.

To post a message you must log in.