Whats the difference between torrents

Asked by Hiro on 2008-03-09


I use kTorrent and the problem I have is that the files download too slow, I checked a similar question but the solution didn't help. For example my current downloading file has 20(106) seeders and 45(482) leecher but the download speed is 30kb/s average. I want to know how to configure the kTorrent. My internet speed is 400 kb/s.


Question information

English Edit question
Ubuntu ktorrent Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:

Please try to disable ipv6 open a terminal and type:

sudo kate /etc/modprobe.d/aliases

give your user password when requested, you don't see nothing when you type it, then press enter.

Search and change the ipv6 row as below:
alias net-pf-10 off # ipv6
then add this row:
alias ipv6 off

To force not load ipv6 kernel module:

sudo kate /etc/modprobe.d/blacklist

add this row:
blacklist ipv6

Reboot your pc.


Elfy (elfy) said : #2

also if you're using a router have you tried enabling upnp

install the upnp plugin - then go to the upnp tab and forward ports


if you're not using kubuntu change sudo kate to

gksudo gedit in ubuntu, gksudo mousepad in xubuntu

Hiro (hhiro) said : #3

Thanks for answer.

But I still have the download speed problem, what's more, now the average is 15kb/s [the upload average is higher].
One thing I have just noticed, in the down left corner there's a sign that says ´no incoming connection (possibly firewalled)´ but I disable the firestarter and nothing changed.

I also downloaded the upnp plugin, but nothing appeared in the detected devices, so when i clicked foward port nothing happened.

I was wondering is there's a way to configured kTorrent to maximize my connection. [I remember I do something similiar in uTorrent].

One more thing: in pretty new in ubuntu. I use ubunyu 7.10


May i suggest you to try deluge (to compare speed)

Open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo apt-get install deluge-torrent

give your user password when requested, you don't see nothing when you type it, then press enter.

You will find deluge under Applications->Internet

Hope this helps

Hiro (hhiro) said : #5

Thanks for the answer marcobra, but deluge downloaded as slow as kTorrent.

1. I have in the lower left corner the yellow triangle icon [I review a question about that but didn't help] that says: no incoming connections (possibly firewalled).

2. The upnp plugin do not show me anything, so i guess I'm unable to foward ports.

3. Things haven't changed at all, I thing with 22 seeders and more than 100 leechers, the down speed should be higher than my current 20 kb/s average. [has never gone over 30kb/s].

note: the ipv6 stuff didn't change anything too.


Elfy (elfy) said : #6

you need to find out which ports ktorrent is using

install firestarter

sudo apt-get install firestarter

then configure the ports to be open


Hope that helps

Ragnar (irnbld) said : #7

I have the same problem. my os is debian. forwarded ports in router. used firestarter. tried different torrent clients. the result is the same - slow speeds. 15k instead of 180. any more suggestions?

Hiro (hhiro) said : #8

I post the problem when I was using ubuntu 7.10 and ktorrent.

But when I update to ubuntu 8.04, I started to use deluge. And my problems disapeared.

I'm currently using ktorrent, and I never figure how to improve de download speed. I hope someone here can hellp you Ragnar.

I close as "Problem Solved" this question.

Hiro (hhiro) said : #9

Sorry a mistake typing in the last post.

line 3:

"I'm currently NOT using ktorrent.."