Torrent programs work in Windows XP but not in Ubuntu 7.10.

Asked by jcm on 2007-11-24

Azureus worked in Windows XP, but not in Ubuntu 7.10. Other torrent programs such as ktorrent, bittorrent dont work either. I did this

iptables -I INPUT -p tcp --dport <your_port_number> -j ACCEPT
iptables -I INPUT -p udp --dport <your_port_number> -j ACCEPT

with the port that comes up in the Nat test for azureus and nothing special seems to happen. by the way, the nat test says everything is ok on that port. UPnP is turned on in azureus (ktorrent also) and nothing happens. I don't think I have any firewalls or virus protection. There is no firewall on my router either.

Since it worked in XP I think it probably is not a router/modem isp problem. dsl modem is an actiontec gt701-wg.

In ktorrent there is that little triangle with a ! but i dont know what that stands for. in azureus there is a nat/firewall problem according to the red dot next to share ratio and how many users are on.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ktorrent Edit question
Assignee:
No assignee Edit question
Solved by:
jcm
Solved:
2007-11-26
Last query:
2007-11-26
Last reply:
2007-11-25

Make sure your Ubuntu Azureus options are the same of your running Windows Azureus.

Then check if you have some iptables rule set: open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo iptables -L

give your user password when requested, you don't see nothing when you type it, then press enter.

Thank you

jcm (johncmetcalf) said : #2

Clicking "restart azureus" did the trick. Sorry for asking a silly question. Thanks for your help though marcobra.