How I start "Ksensors" after download?

Asked by Luis M.Jacinto on 2010-02-13

From Synaptic manager I download "Ksensors" but now I don't know how to install it.
Please help.
Thank you

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ksensors Edit question
Assignee:
No assignee Edit question
Solved by:
Ray_GTI-R
Solved:
2011-02-17
Last query:
2011-02-17
Last reply:
2010-11-13
Bhaskar Kandiyal (bkandiyal) said : #1

If you have installed the package from Synaptic, then it should appear in the Applications->Accessories menu named 'Ksensors'.

Or you can run it from the 'Run Application' dialog, press Alt+F2, a dialog box will pop up and type in it 'ksensors'
(without quotes) and press Enter.

Luis M.Jacinto (ljacinto) said : #2

In Accessories Ksensors is not showing.
In 'Run Application' this error come up:Error stating file '/home/luis/Ksensors': No such file or directory.
I am using Ubuntu 9.10 and I am a novice.
Thank you

Bhaskar Kandiyal (bkandiyal) said : #3

Well, what I can think of right now is, first of all open up a terminal (Applications->Accessories->Terminal) and then type in 'ksensors' (The case matters here, so type it all in lower case, please keep in mind that Linux is case sensitive, so 'A' and 'a' are not the same thing) :) and hit Enter.

It will launch ksensors, or it will print out some errors (if there is any error starting ksensors, etc.), if there are any errors then please paste the error messages here :)

Luis M.Jacinto (ljacinto) said : #4

Result of 'ksensors' in Terminal:
luis@luis-desktop:~$ ksensors
DCOPClient::attachInternal. Attach failed Could not open network socket
DCOPClient::attachInternal. Attach failed Could not open network socket
kbuildsycoca running...
KSensors error: sensors_init fail, error code -4
luis@luis-desktop:~$

Bhaskar Kandiyal (bkandiyal) said : #5

I tried installing ksensors myself and searched around, it's a bit buggy with the new kde 4. When you run it from the terminal and get the error "KSensors error: sensors_init fail, error code -4", check your system tray, there should be an icon for ksensors.

Right click and select 'Configure' and choose your desired options. This worked for me, but still it's a lot buggy and I don't recommend using it.

If you're trying to monitor CPU load and stuff, you can use 'gkrellm' (sudo apt-get install gkrellm, from a terminal) or search for 'gkrellm' in Synaptic.
It's installed under Applications->System Tools->GKrellM System Monitor.

Luis M.Jacinto (ljacinto) said : #6

Thank you for you help, it was in the system tray, but in 'Configure' I dint find
temperature for hard disk and processor so I my following your advice and
replace with GKrellM.

Best Ray_GTI-R (ray-w) said : #7

I am replying here because this is the top reply in Google search ...

This is my 2-second solution:-

Click Accessories
Click Terminal
Type "ksensors" (without the quotes)
When finished (some stupid error messages ALWAYS appear) and ksensors starts ... click on the Terminal window and type Exit.

Long-winded I know and primitive as it's 2010 :-{

HTH, Ray

FWIW I LUV KSENSORS BUT IN UBUNTU 10.10 (FULL UPDATES) THE CPU CORE # IS NOT SAVED (EVERYTHING ELSE IS !!!???!!!):- I HAVE TO RE-ENTER AND RE-ENTER THESE EVERY TIME I START ksensors.
FWIW2 Downloading & installing ksensors in Ubuntu 10.10 is a nightmare.
FWIW3 I don't care if ksensors ISN'T FLAVOUR OF THE MONTH/TRY XYZ ... ksensors does the job extremely well and it should be supported in Ubuntu, version whatever.
FWIW4 the previous release of Ubuntu had most of these problems but at least I could save the CPU ref#'s !!!???!!!
FWIW5 see see FWIW3

Luis M.Jacinto (ljacinto) said : #8

Thanks Ray_GTI-R, that solved my question.