kredentials complains "Unable to run aklog"

Asked by Jens Jorgensen

Binary package hint: kredentials

I just installed a box fresh from a Lucid Lynx Beta 1 disc. Also I've kept it up-to-date with apt-get dist-upgrade. I like to run kredentials to keep my kerberos credentials going. I discovered that in this version I get an error window (system-modal, no less) complaining "Unable to run aklog". I had no idea what aklog was at the time, I'd never seen this before and I've been using kredentials for a long time. I discovered that aklog is part of the package openafs-krb5. Well, I'm not using AFS. Apparently aklog is supposed to get AFS credentials. I tried running aklog from the command-line just to see and indeed it comes back with an error message. I also tried uninstalling the package, thinking perhaps if kredentials cannot find the program it won't worry about running it. No such luck, I still get the error window. It seems to me that kredentials should not be showing this error. Here's the requested additional info:

Description: Ubuntu lucid (development branch)
Release: 10.04

  Installed: 0.9.4+nmu1ubuntu1
  Candidate: 0.9.4+nmu1ubuntu1
  Version table:
 *** 0.9.4+nmu1ubuntu1 0
        500 lucid/universe Packages
        100 /var/lib/dpkg/status

Question information

English Edit question
Ubuntu kredentials Edit question
No assignee Edit question
Last query:
Last reply:

This question was originally filed as bug #553817.

Revision history for this message
Jon Proulx (jproulx) said :

The application works as documented, if not as expected.

Revision history for this message
Jon Proulx (jproulx) said :

run 'kredentials -d' to run without aklog

/usr/bin/kredentials --help-all


 -i, --inform Inform the user when credentials are renewed
-d, --disable-aklog Don't run aklog after renewing Kerberos tickets

(it may be better to make running _with_ aklog a command line option , but this is how it is today...)

Can you help with this problem?

Provide an answer of your own, or ask Jens Jorgensen for more information if necessary.

To post a message you must log in.