When is kopete going to support the 'new' ssl method for jabber connecting to port 5222?, pidgin has had this for ages now.

Asked by stevenjoseph on 2011-08-01

Im trying to connect to a private jabber server, I'm able to connect to it using pidgin without any issues.
This does not work with kopete no matter what configuration I try. After a lot of digging I suspect it is because kopete still uses the old style method of ssl connection. I would really like this to be fixed, I love using kopete, with out it now my kde experience feels a bit incomplete.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu kopete Edit question
Assignee:
No assignee Edit question
Last query:
2011-08-02
Last reply:
2011-08-05

What version of Ubuntu are you running?

If you are running Ubuntu 10.10 or earlier, you may be able to fix SSL authentication problems in Jabber connections by installing the package called qca-tls. (See http://kopete.kde.org/faq.php#JabberSSLsupportstoppedworkingIgetthemessagethattheQCATLSpluginisprobablymissingWhatamIsupposedtodo and https://launchpad.net/ubuntu/+source/qca-tls.)

What is the output of:

lsb_release -a; apt-cache policy kopete

Thanks

stevenjoseph (stevenjoseph) said : #3

I Just upgraded to oneric to see if it might resolve the issue but .. nope.

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu oneiric (development branch)
Release: 11.10
Codename: oneiric
kopete:
  Installed: 4:4.7.0-0ubuntu1
  Candidate: 4:4.7.0-0ubuntu1
  Version table:
 *** 4:4.7.0-0ubuntu1 0
        500 http://mirror.optus.net/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status

I suggest you log a bug and it may get added

Before reporting this or any other bugs in Ubuntu, please read https://help.ubuntu.com/community/ReportingBugs carefully (if you have not done so already).

Can you help with this problem?

Provide an answer of your own, or ask stevenjoseph for more information if necessary.

To post a message you must log in.