Knetworkmanager only shows wired networks

Asked by Paul on 2007-04-21

I just upgraded to the new Kubuntu 7.04. Knetworkmanager showed all the possible wireless connections at first but now it doesn't. When I click on knetworkmanager Icon the only option is manual configuration. Is there something I could have done to make it not show the wireless connections?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu knetworkmanager Edit question
Assignee:
No assignee Edit question
Last query:
2007-04-21
Last reply:
2007-11-26
linuxboy (jacobc) said : #1

same problem for me at first it worked and then nothing !
I don't know how to do to see wireless access point ? this problem is about the latest release 0.1-0ubuntu12
thx

mcarpe (matteo-carpentieri) said : #2

Same problem for me. I can access the net with my wireless card (wlan0) but knetworkmanager only shows eth0 (wired network). I can only manually configure the net...

I just switched from edgy eft to feisty fawn and the wireless card is using ndiswrapper..

nossifer (oneleggedracer) said : #3

same problem. installed feisty. knetwork manager worked out of the box (big relief). now it doesn't. only showing my wired, and now, not even that.

manual config of wireless keeps putting in the wrong IP. also, gateway keeps reverting back to 0.0.0.0

jcervilla (jcervilla) said : #4

I have the same problem, too. And I can't see the WPA option in the configuration.

Thanks

Soundmonster (leolinux) said : #5

I have deleted all wireless-related entries from /etc/network/interfaces. Now my KNetworkManager shows wired networks again. My home network works fine using WPA-PSK.

BTW, manual config which used to work with breezy, doesn't work anymore. KNetworkManager seems to work fine.

jcervilla (jcervilla) said : #6

Yes, I have done it, and then I was able to see the wireless networks, but I was not able to configure them. It didn't work fine, and I configured my network in manual way. But then, I'm not able to see the wireless networks. So I'm not using it. When it works, I can see the WPA config screen.

marcelol (marcelol240) said : #7

same boat, using ndiswrapper. wireless network ( heck, even the interface, which it named eth1?? ) interface has to be enabled via Network connections applet in Administrator mode only. I can't disable/enable the interface via KNetworkManager to save my life.

FilipK (filip-koczorowski) said : #8

Although this question is marked as "answered" I can't find a solution. I have the same problem as other people here - knetworkmanager doesn't show wireless options in the menu (meaning I have only "Manual configuration", "Options", "Help" and "Quit"). My WiFi card seems to be configured OK with ndiswrapper ("iwlist wlan0 scan" shows proper information about Access Points) and I don't have any wireless-related entries in /etc/network/interfaces. What am I doing wrong?

linuxboy (jacobc) said : #9

hi,
I resolved in reinstalling it !!
try this & reboot...

++

marcelol (marcelol240) said : #10

linuxboy.......What ??? No way, I installed and then re-installed Kubuntu, and I STILL have to manually configure the network for it to pick up.

And for that matter......why is there no support for LEAP in KNetworkManager.

If only I could get wpa_supplicant to work, then I'd switch to Kwlan, at least it's supposed to support LEAP configurations.

linuxboy (jacobc) said : #11

hey,
there is nothing wrong with kubuntu, you don't need to reinstall it each time you get a problem !!! :S
I don't know about Knetworkmanager support for wireless routers from LEAP...
I use WEP and I am satisfied :D

The initial problem was, "Knetworkmanager works the first time, and then doesn't show wireless networks anymore..."
so i installed the latest release but still nothing so I removed knetworkmanager and I installed it once more.....finally evrything is fine :D

@++

nossifer (oneleggedracer) said : #12

WEP can be cracked by your grandmother. there is a wep cracker in teh package manager.
i am using it now too with little alternative. :(
> To: <email address hidden>> From: <email address hidden>> Subject: Re: [Question #5327]: Knetworkmanager only shows wired networks > Date: Thu, 10 May 2007 21:28:51 +0000> > Question #5327 on knetworkmanager in ubuntu changed:> https://answers.launchpad.net/ubuntu/+source/knetworkmanager/+question/5327> > linuxboy proposed the following answer:> hey,> there is nothing wrong with kubuntu, you don't need to reinstall it each time you get a problem !!! :S> I don't know about Knetworkmanager support for wireless routers from LEAP...> I use WEP and I am satisfied :D> > The initial problem was, "Knetworkmanager works the first time, and then doesn't show wireless networks anymore..." > so i installed the latest release but still nothing so I removed knetworkmanager and I installed it once more.....finally evrything is fine :D> > @++

nossifer (oneleggedracer) said : #13

OH NO!!!!

guys, i replied to the email i got within the email and now i accidentally put my email address into this forum. Can someone manually remove it for me before every spider on the planet seeks me out ?

WWWWHAAAOOOOH!!!!

hope you can. chris

linuxboy (jacobc) said : #14

my grandmother is dead :( don't talk shit ....Anyway If you know how to configure a router you don't even need to encrypt the access, NOOOOOOOOOOBBBBBBBBB ...
I am waiting for some excuses otherwise I will enjoy to spam on <email address hidden> :D

nossifer (oneleggedracer) said : #15

sorry to hear of your loss.

are you referring to not broadcasting the router name, or is there some other configuration you are referring to? can you please expand on your claim?

marcelol (marcelol240) said : #16

The issue is as follows...maybe I need to open another bug.

BCM43xx doesn't natively work with BCM4306 ( Dell Truemobile 1300 ). Therefore, KNetworkManager doesn't show a wireless interface exists.

If I blacklist bcm43xx, install ndiswrapper, and import the .INF/.SYS files from the DELL download site for the wireless card,
then

ndiswrapper -m
modprobe ndiswrapper

and reboot. Then KNetworkManager still doesn't show the SSID that broadcasts. I have to go to Network Administration, go to Administrator Mode, and physically ENABLE the interface the first time, for KNetworkManger to see it ( every subsequent boot seems to have it automatically detect the SSID now ). I then have to MANUALLY configure the SSID for the proper encryption (WEP, since it's just for guests ).

However, KNetworkManager does not support LEAP configuration for another SSID that is NOT broadcasting. This is for the people who work here.

I've thought of switching to wpa_supplicant for those who're supposed to be configured for office use, and then Kwlan as the UI, but

A) KNetworkManager isn't compatible with wpa_supplicant ( not sure why, I'm not a linux networking guru )
B) If I install kwlan via adept, it uninstalls KNetworkManager
C) If I try to run wpa_supplicant then and have it use ndiswrapper and eth1 ( for some reason Kubuntu sets my wifi up as eth1 instead of wlan0, etc. ), and this is where everything fails.

This is where I'm stuck. If KNetworkManager won't support LEAP, and wpa_supplicant won't import and create a config for an ndiswrapper configured driver, then there's a problem.

FilipK (filip-koczorowski) said : #17

Just for those of you with still no luck - after some forum reading I removed everything except

auto lo
iface lo inet loopback

from /etc/network/interfaces file and now I have wireless networks in knetworkmanager.

tdn (spam-thomasdamgaard) said : #18

knetworkmanager stopped working. It does no longer show available networks. I need to manually edit /etc/network/interfaces to get on the network. How do I fix this? This is my /etc/network/interfaces: http://thomasdamgaard.dk/p/P605.html.

Jim Hutchinson (jphutch) said : #19

To do as FilipK suggests just open the file

sudo kate /etc/network/interfaces (replace kate with any editor. I think kate is the right one but I don't use kde)

and then make the file look like this:

auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

#auto eth0
#iface eth0 inet dhcp

#auto eth1
#iface eth1 inet dhcp
#wireless-essid opennet

#auto eth2
#iface eth2 inet dhcp

#auto ath0
#iface ath0 inet dhcp

#auto wlan0
#iface wlan0 inet dhcp

Now, whether or not that will fix your problem i can't say. That is just editing it as FilipK suggested. If you need more help, I suggest opening your own question. If you do that, be sure to provide as much info as possible - eg. a clear description of the problem you are seeing, what you have tried, whether it used to work or not have what has changed, etc.

tdn (spam-thomasdamgaard) said : #20

 Jim Hutchinson: I will try that right now.

tdn (spam-thomasdamgaard) said : #21

 Jim Hutchinson: it worked!

Yes. It worked. thanks

mattcasters (matt-casters) said : #23

Fix confirmed on Gutsy/Kubuntu - Dell Precision M64 - PRO/Wireless 3945ABG Network Connection.

However, after deactivating the wireless connection, knetworkmanager doesn't pick up the wired connection.
Going to off-line mode and back to on-line mode fixes that. However, it would be nice if you could do that automatically.

Can you help with this problem?

Provide an answer of your own, or ask Paul for more information if necessary.

To post a message you must log in.