KNetworkManager not showing connection

Asked by Brian Harkness on 2007-04-10

Upon recent update, KnetworkManager shows an red x in the tray icon, even though I have a connection and if I select "Options - Show networks" my wireless connection is there... rebooted a few times and looks the same. Downloaded KWifiManager in the interim. Please advise.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu knetworkmanager Edit question
Assignee:
No assignee Edit question
Solved by:
Scott Kitterman
Solved:
2007-04-13
Last query:
2007-04-13
Last reply:
2007-04-13
os2mac (os2mac) said : #1

I am showing similar indications. Accept when I right click on the icon I see the indication "wired connection" and doesn't show any connected networks.

casper (kumar27-devils) said : #2

same problem here !

Antonio (apedic) said : #3

i'have the same problem after an upgrade of feisty

ema84 (emanuele-tatti) said : #4

same problem here after an upgrade

Brian Harkness (maestro-bwh) said : #5

Was kind of hoping after today's update that this would be fixed. I saw some things relating to network-manager and perhaps a new kernel update, but the issue persists.

Best Scott Kitterman (kitterman) said : #6

There is another update for Knetworkmanager that's just been uploaded that resovles a number of potentially related issues. Please try knetworkmanager 0.1-0ubuntu12 and see if it solves your problems.

For those unable to get any wireless networking working after upgrade to Feisty, please make sure you have the latest linux-restricted modules installed.

Brian Harkness (maestro-bwh) said : #7

Thanks Scott Kitterman, that solved my question.

Trojkolka (trojkolka) said : #8

since a couple of days available wireless networks don't show up anymore when clicking on the networkmanager tray icon. It still makes a connection but it doesn't show the strength of the signal or other wireless networks in the surroundings. Is this related to this problem? I've update my Feisty couple of minutes ago and it still doesn't seem to work the way that it worked before. I got a Intel pro wireless 2200wg card on my laptop and i'm running on Kubuntu feisty,

casper (kumar27-devils) said : #9

knetworkmanager 0.1-0ubuntu12 didn't solve problem in my machine. its changing Icon on toggling online/offline mode but it doesn't activate/deactivate wired connection. Feisty is fully upgraded and Knetworkmanager was working fine a few days back.

Scott Kitterman (kitterman) said : #10

Please include the contents of /etc/network/interfaces in a reply to this question.

casper (kumar27-devils) said : #11

contents of /etc/network/interfaces:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

iface eth0 inet static
address 192.168.1.5
netmask 255.255.255.0
gateway 192.168.1.1

auto eth0

Scott Kitterman (kitterman) said : #12

It looks to me like something changed your interfaces file. I'm not sure if it will matter, but try to change it to look like this and then reboot:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

# The primary network interface
auto eth0
iface eth0 inet static
address 192.168.1.5
netmask 255.255.255.0
gateway 192.168.1.1

casper (kumar27-devils) said : #13

no change. its changing Icon on toggling online/offline mode as earlier.

Scott Kitterman (kitterman) said : #14

Then at this point I'd suggest filing a bug on Launchpad as the problem you are having appears to be a different one then they have been trying to fix. Make it dlear which versions worked and which ones didn't.

Nando_uy (fdiazuy) said : #15

First... sorry for my english, my natal language are spanhish.

I have Feisty 7.04 upgraded from Edgy 6.10, a Acer Aspire 5570 laptop with Atheros AR5005G.
I have the same problem. knetworkmanager don't show others wireless networks and don't allow to connect to networks with encryption different of wep because don't show the options to connecto to others networks.

I'VE SOLVED THIS PROBLEM. In my /etc/network/interfaces I had typed by hand an static ip, ssid and wep key. Erasing that and changing in /etc/network/interfaces for:

auto ath0
iface ath0 inet dhcp

knetworkmanager now works fine and show me others networks and gives the possibility of change encryption (wpa-tkip, wpa-aes, etc) and connecting me to other networks.

Hey. Maybe the answer is related to this question:

https://answers.launchpad.net/ubuntu/+source/knetworkmanager/+question/5327