No WPA2

Asked by katjana on 2008-07-16

Hi
I am running Hardy KDE 3.5. Last night I saw some new updates had come in, and I am not sure what they were. but I downloaded them as I always do. I was asked whether I wanted to allow adept overwrite the grub menu list, so I guess there was some kernel update.

Today there there is no longer any WPA2 option in my network manager, and I can no longer connect WIFI. I have had very stable wifi for some months, also with Gutsy, after I configured my router for WPA2. Using Broadcom (currently B43).

What should I do? Reinstall network manager?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu knetworkmanager Edit question
Assignee:
No assignee Edit question
Last query:
2008-07-18
Last reply:
2008-07-19
Theodotos Andreou (theodotos) said : #1

Try reinstall "wpasupplicant" and "kwlan" instead.

katjana (katjedw) said : #2

Yes, thank you, but I evidently did it the wrong way! I uninstalled the wepasupplicant I had, and lost all contact also with the cabled network. What whould I do now?

katjana (katjedw) said : #3

I have now disabled encryption on the router. I followed directions for manual wifi-connect on the Ubuntu forums thus: (my interface is wlan0)

sudo ifconfig <interface> down
sudo dhclient -r <interface>
sudo ifconfig <interface> up
sudo iwconfig <interface> essid "ESSID_IN_QUOTES"
sudo iwconfig <interface> mode Managed
sudo dhclient <interface>

The output was fine (I think) until I got to the bottom line: No working leases in persistent database - sleeping.

Theodotos Andreou (theodotos) said : #4

Assign a static IP on the cabled interface so that you can get on the internet:

  ip addr add <ip-address>/<cidr-mask> dev eth0

Define a default gateway:

  ip route add default via <ip-of-gateway> dev eth0

katjana (katjedw) said : #5

ip route add default via <ip-of-gateway> dev eth0

returned: "no such process"

Result: I was still unable to connect by cable. So I reinstalled my Kubuntu by restoring a partimage backup of the partition. Cable conection ok.
After having enabled all the 107 adept upgrades waiting for me,
cable connection ok, but no WIFI connection.
I used the adept GUI to install kwlan.
Result: No WIFI and no cable connection (!) No internet connection at all.
So now I am once again reinstalling from partimage backup. I shall give up WPA2 encryption for the time being.

Theodotos Andreou (theodotos) said : #6

This looks like a bug. Check under Bugs if someone has reported a similar problem. If not report it as a bug.

Can you help with this problem?

Provide an answer of your own, or ask katjana for more information if necessary.

To post a message you must log in.