knetworkmanager wireless stops at 28%

Asked by Newt on 2008-07-08

I am running Kubuntu 8.0.4 and have a Gateway M6846 laptop with an Intel Pro/Wireless 3945ABG wireless card. When I attempt to connect to the router (via wireless), the connection manager stops at 28% and after a few minutes, I get a connection error. I am using WPA encryption and am typing in my password correctly.

The wired portion of knetworkmanager works fine.

I searched around and didn't see any similar issues.

Thanks in advance.

Curt

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu knetworkmanager Edit question
Assignee:
No assignee Edit question
Solved by:
Steven Rose
Solved:
2008-07-13
Last query:
2008-07-13
Last reply:
2008-07-08
Newt (newtoncd) said : #1

BTW, the 28% stopping point is Activation Stage: Configuring device.

The error I get is:
Connection Failure
Count not connect to the network.

Steven Rose (steveydoteu) said : #2

You say you are entering the correct password, are you sure you are not mistaken in what the WPA key actually is?

It should be a series of letters and numbers, around 12 characters long. You would find it on the back or bottom of your router, probably near the serial number.

Be sure to note and select the correct key type as well, 128-bit ASCII, 128-bit hex, 64-bit ASCII, 64-bit hex or similar.

Newt (newtoncd) said : #3

Interesting .... I made a <bad> assumption it was simply asking for the network password for when I set the router up. I will go down and look up the router info. I will post back.

Newt (newtoncd) said : #4

I just checked and the only info on the router is the IP address to log into it, the serial and the MAC address. Nothing regarding WEP, WPA, etc.

Steven Rose (steveydoteu) said : #5

Okay, well firstly, do any other computers need a WEP or WPA to connect wirelessly?

If the case is no, you need to set the wireless manager to no encryption.

Failing this what is the brand and model of router?

Newt (newtoncd) said : #6

Yes, we have another laptop in the house that runs Windows XP Home and connects via WPA. My wife's computer is via ethernet. We also have a wireless printer that is connected via WPA.

My router is a Netgear WPNT834 and it has the latest firmware and when I boot into Windows, my laptop connects fine via Vista Home SP1.

One of my neighbors doesn't have his network encrypted and I am able to connect to his router via Linux fine.

So, it has something to do with the WPA and my router.

Thanks again for your help.

Steven Rose (steveydoteu) said : #7

Well, when setting up the printer and also the other machine, you must have found the WPA key somewhere to use it.

Newt (newtoncd) said : #8

Correct, I know the WPA key (which I incorrectly referred to as my password).

I am going to try another version of Linux to see how it works...I will report back.

Best Steven Rose (steveydoteu) said : #9

If you are certain it is the correct key and in the correct format, it may well be the fact it is an Intel Pro Wireless jobby.

The default drivers appear to be working, but the firmware behind it is crap. You will probably have no issues what so ever joining open networks, but anything encrypted will cause a problem.

I suggest looking over the following:

http://support.intel.com/support/notebook/sb/CS-006408.htm

Steven Rose (steveydoteu) said : #10

If you still have no luck provide me with the contents of an lspci command focused on the wireless components, and I will look into it further when I have some spare time.

To do this open a terminal and type:

lspci | grep Wireless > wireless.txt

Press enter

Browse to your home directory and open the created text file, past the contents of it here.

Newt (newtoncd) said : #11

Thanks again for your help ... the output of the file is:

02:00.0 Network Controller: Intel Corporation PRO/wireless 3945ABG Network Connection (rev 02)

Newt (newtoncd) said : #12

Disregard, I installed OpenSuse and the network connection using WPA encryption is working great (I am posting from Linux now). Not sure why the kubuntu version doesn't work, but OpenSuse does.

Steven Rose (steveydoteu) said : #13

Seems a little odd to say the least.

Newt (newtoncd) said : #14

Understand, wish I could explain it. I was able to install my HP C6180 all-in-one in Linux and things are working great. Appreciate your assistance.

Steven Rose (steveydoteu) said : #15

Not a problem, could I ask you to mark this as solved if you no longer require assistance please?

Newt (newtoncd) said : #16

Thanks Steven Rose, that solved my question.