knetworkmanager drops wireless session < 1min after it connects

Asked by xeoron on 2008-03-09

I am trying to setup a desktop Kubuntu (Gusty Gibbon) pc to a wifi router. After knetworkmanager makes a secure wireless wpa connection the session drops within a minute. What must be done so that the authenticated session does not disconnect?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu knetworkmanager Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
2008-03-09
Last query:
2008-03-09
Last reply:
2008-03-09

Please try to disable ipv6 open a terminal and type:

sudo kate /etc/modprobe.d/aliases

give your user password when requested, you don't see nothing when you type it, then press enter.

Search and change the ipv6 row as below:
alias net-pf-10 off # ipv6
then add this row:
alias ipv6 off

To force not load ipv6 kernel module:

sudo kate /etc/modprobe.d/blacklist

add this row:
blacklist ipv6

Reboot your pc.

HTH

xeoron (yubnub) said : #2

That did not seem to work... I am thinking that perhaps the /etc/hosts file needs ip6 disabled too. I would test it, but I have hit another problem, which is this: Knetworkmanager nolonger offers me the ability to access the choose Other Wireless Network settings-- where I tell it, which SSID to target and password settings to use.

xeoron (yubnub) said : #3

Ok that 2nd problem is fixed using
1. Install gnome-system-tools
2. Run "sudo network-admin"
3. Click a network, click "Properties"
4. Enable "roaming mode"

(which is explained here: https://answers.launchpad.net/ubuntu/+source/knetworkmanager/+question/8140 )

After 10 minutes of use no problems... will restart the system and report back if anything breaks.

xeoron (yubnub) said : #4

It's working fine *smiles* Thanks Microbra

xeoron (yubnub) said : #5

Thanks marcobra, that solved my question.