KNetworkManager Manual Configuration

Asked by druidfire217 on 2007-10-17

I am having trouble getting the Network Manager to respond automatically. I am trying to get two or more different wireless keys stored in the network manager, as well as trying to get the Network Manager to automatically search out and identify networks. Currently I am having to enter the Network name, as well as the WEP key every time I change it, and the system tray icon never changes to the scale, but instead stays in some kind of plug looking icon. Can anyone help? Thanks!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu knetworkmanager Edit question
Assignee:
No assignee Edit question
Last query:
2007-11-08
Last reply:
2008-11-24
daskinil (terrilsj) said : #1

I'm having exactly the same problem. After installing Kubuntu Gutsy Gibbon, Knetworkmanager worked for only a few hours. Now its stuck in the "plugged in" icon and the only options from right-clicking on the system tray applet is "Manual Configuration" and the Options and Help submenus. Has anyone else experienced this problem or found a fix?

Marco Cimmino (cimmo) said : #2

open /etc/network/interfaces and comment all wlan0 (or the number of your wireless interface) related lines, should work.

I know this sucks, no option to force this in knetworkmanager!!!

druidfire217 (gtg834q) said : #3

Now it is telling me I do not have authorization to save the file to that place. I have a eth2, which is my wireless card, as well as wlan0, which doesnt seem to be associated with anything. I am using a PCI wireless card, if that makes a difference.

arigh (arighauks) said : #4

I had the exact same problem (as stated in the original problem).
I opened up /etc/network/interfaces and ended up commenting (for newbies, this means adding a # foremost in the line) out the lines:

iface eth1 inet dhcp
wireless-essid SOME_NETWORK_NAME
wireless-key s:SOME_NETWORK_NAME_KEY

and what was left was:

auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

auto eth1

This seems to work for me (note that eth1 is my wireless card and YMMV)

Please post back to this thread if you find something useful on it... Thanks ;)

Baltor (baltor-wfb) said : #5

I comment the lines as indicated above and my wireless became work. Thanks.

Manuel Bärenz (turion) said : #6

Please check that you don't have different interfering applications/daemons managing your connections, and as well installed properly your device drivers (ndiswrapper, bc43fwcutter, what else)

Druidfire, to edit such a file, you need root access. This means, in Ubuntu, try for example
kdesudo kwrite /etc/network/interfaces which will prompt you for your password.

If you are not using kwallet, give it a try managing your passwords with it. Set up a wallet in KWallet if you don't have one, restart your computer and change the settings of KNetworkManager to "Store Keys in KWallet"

Can you help with this problem?

Provide an answer of your own, or ask druidfire217 for more information if necessary.

To post a message you must log in.