edit function doesn't work

Asked by Joe Beall

I just re-installed KMymoney in Ubuntu 9.10 (also newly re-installed) and used my backup files to restore my data but I found that I can't edit any amounts. I have recurring loan payments and the principal/interest split varies each month so I simply have been editing the original to fit and this worked fine in my old installation, but not now.

Question information

English Edit question
Ubuntu kmymoney2 Edit question
No assignee Edit question
Solved by:
Hei Ku
Last query:
Last reply:
Revision history for this message
Hei Ku (asoliverez) said :

When you say you can't edit, can you be more specific?

The edit button is disabled, you can edit, but then you can't save the changes, etc?

Revision history for this message
Joe Beall (joe-beall) said :

Hello Hei Ku,
The edit button works OK (as does "edit splits") but when I highlight the figure I want to change the highlighting disappears and the cursor doesn't move. If I use the "backspace" key I can delete the value but nothing happens when I try to write the new value. The same thing happens when I use the "Delete" key instead of the "backspace". In my previous installation I could just overwrite my new value on the old one once I had highlighted it.

Revision history for this message
Best Hei Ku (asoliverez) said :

Something is wrong with your installation.
Which version did you have before and which version are you running now?

Revision history for this message
Joe Beall (joe-beall) said :

I thought that might be the case. My previous KMymoney installation was done through 9.04 (I upgraded to 9.10) but my latest installation was done after formatting my HD and then installing 9.10 directly from CD and not through upgrade. I have a feeling that that may have something to do with my problem. Also, my Canon MP620 doesn't want to work any more in the direct 9.10 installation and I saw a thread addressing this issue that suggested installing 9.04 first and upgrading to 9.10, just as I had done earlier. Maybe that will solve both issues. With that in mind I'm now in the process of re-formatting the HD and starting over. Thanks for your efforts.

Revision history for this message
Joe Beall (joe-beall) said :

Thanks Hei Ku, that solved my question.

Revision history for this message
Joe Beall (joe-beall) said :

I must appologize to forum members (especially Hei Ku) for being a "Num"-Skull and not noticing that my "Num Lock" key had been disengaged at some point during the process of formatting my HD. Once I re-engaged "Num Lock" my editing problems in KMyMoney disappeared.
Again, sorry for all the possible head-scratching my "problem" may have caused.

Revision history for this message
Hei Ku (asoliverez) said :

No problem. Glad you solved it.