kino mpeg4 dv conversion

Asked by Tony Mason-Sherwood on 2008-03-01

When trying to import AVI files into Kino there is a problem with the conversion that causes the DV file to only have about 1/3 of the frames of the original file. It appears to but speeded up when I play it. The audio track has information that is missing.
I have experimented with ffmepg which is what Kino uses to do the conversion and I am able to convert files with the same problem from the command line. I have tried many variations but a basic request is sufficient to duplicate the probelm
ffmpeg -i video.avi -target ntsc-dv video.dv is sufficient to duplicate it.
The audio rate is 22050 for the avi file and setting it for the input file in ffmpeg does not change the problem. I know DV must use 44100 audio rate. When I run it I get an error
[dvvideo@0xb7e2cac8]Can't process DV frame #40. Insufficient audio data or severe sync problem.
What appears to happen is incomplete audio information causes multiple frames to be overwritten. When I use ffmpeg and the -an switch which turns off the audio conversion I get all the frames in the DV output. The files I am using are comming from the Samsung SC-MX10 camcorder which uses SD cards for storage. It writes each video take as a separate avi file.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu kino Edit question
Assignee:
No assignee Edit question
Solved by:
Tony Mason-Sherwood
Solved:
2008-03-02
Last query:
2008-03-02
Last reply:
2008-03-02

Please try if new version of kino works better:

http://www.getdeb.net/app/Kino

Hope this helps

Tony Mason-Sherwood (tmason) said : #2

The problem was caused by my using a video that was progressive rather than interlaced. I need to find out more about the relationship with ffmpeg and progressive scanned videos. As soon as I set the mode of the camera to shoot 480i instead of 480p the import worked properly.

borhyl (borhyl) said : #3

If you take a film with Samsung in "p" resolution you have to repair the samsung *.avi file by:
mencoder -idx film.avi -ovc copy -oac copy -o film_fix.avi Then it should work with Kino import without any problem in Ubuntu. For installing the mencoder package type in shall:
sudo apt-get install mencoder