Use Keystone to authenticate - Issues with REST API query - help!

Asked by Karlis Peterson

I am new to OpenStack and trying to get an authentication token. I get errors and maybe someone can provide me with some guidance. I have tried with Postman client and curl script.

Base url:

I have a basic user: user123
password: pass123
Domain: I assume default? Is that correct? I do not think domain-ids have been created
methods: password (I assume)
user123 is part of 2 separate Tenants

I have tried the following:

curl -i --insecure -X POST -H "Content-Type:application/json" -d "{"auth": {"scope": {"project": {"domain": {"id": "default"},"name": "user123"}},"identity": {"password": {"user": {"domain": {"id": "default"},"password": "pass123","name": "user123"}},"methods": ["password"]}}}"

I get errors:

"Expecting to find application/json in Content-Type header - the server could not comply with the request since it is either malformed or otherwise incorrect..."

Please help with the format above! Thank you in advance!!


Question information

English Edit question
Ubuntu keystone Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

Can you help with this problem?

Provide an answer of your own, or ask Karlis Peterson for more information if necessary.

To post a message you must log in.