Is it possible to backport a newer version of keepalived to bionic?

Asked by Adam Harwell on 2019-06-19

The Openstack/Octavia project is looking to do UDP load-balancing with address-family translation, and it seems this is only supported properly in keepalived 1.4.5+. Bionic (and even Cosmic) only have 1.3.9 available. It seems Disco has upgraded the version to 2.0, so it would be available in that release, but Bionic is still the latest LTS release. Would it be possible to backport a slightly newer version (like 1.4.5) or even 2.0 to bionic-updates?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu keepalived Edit question
Assignee:
No assignee Edit question
Last query:
2019-06-19
Last reply:
2019-06-20

You may find a PPA for it
https://launchpad.net/ubuntu/+ppas?name_filter=keepalived

Remember to filter each PPA for Bionic to make sure it has the package for your release.

Obviously this comes with the usual caveats of a PPA etc.

Can you help with this problem?

Provide an answer of your own, or ask Adam Harwell for more information if necessary.

To post a message you must log in.