cannot build project

Asked by Esa-Petri on 2007-06-04

I am new in both c and c++ and I am trying to build example projects but I gain This kind erors when building it
cd '/home/esa-petri/Työpöydä tavarat/Ohjelmointi/Test' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" make -f Makefile.cvs && cd '/home/esa-petri/Työpöydä tavarat/Ohjelmointi/Test/debug' && CXXFLAGS="-O0 -g3" "/home/esa-petri/Työpöydä tavarat/Ohjelmointi/Test/configure" --enable-debug=full && cd '/home/esa-petri/Työpöydä tavarat/Ohjelmointi/Test/debug' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" make -k
 aclocal
  configure.in:8: warning: macro `AM_PROG_LIBTOOL' not found in library
 autoheader
 automake
 autoconf
 configure.in:8: error: possibly undefined macro: AM_PROG_LIBTOOL If this token and others are legitimate, please use m4_pattern_allow. See the Autoconf documentation.
make: *** [all] Virhe 1
*** Exited with status: 2 ***
please give somehelp

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu kdevelop Edit question
Assignee:
No assignee Edit question
Solved by:
Esa-Petri
Solved:
2007-10-17
Last query:
2007-10-17
Last reply:
2007-06-04

This question was reopened

Ralph Janke (txwikinger) said : #1

Thanks for the question.

Have you installed the package build-essential? It looks like you missing some standard development packages.

I hope this helps

Esa-Petri (esapete) said : #2

Thanks Ralph Janke, that solved my question.

Esa-Petri (esapete) said : #3

new proplem apeared how I do fix thease
cd '/home/esa-petri/Työpöydä tavarat/Ohjelmointi/Test' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" make -f Makefile.cvs && cd '/home/esa-petri/Työpöydä tavarat/Ohjelmointi/Test/debug' && CXXFLAGS="-O0 -g3" "/home/esa-petri/Työpöydä tavarat/Ohjelmointi/Test/configure" --enable-debug=full && cd '/home/esa-petri/Työpöydä tavarat/Ohjelmointi/Test/debug' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" make -k
aclocal
autoheader
automake
autoconf
installing -c
checking whether build environment is sane...
configure: error: ls -t appears to fail. Make sure there is not a broken
alias in your environment
configure: error: newly created file is older than distributed files!
Check your system clock
*** Exited with status: 1 ***

Benoit Malet (benoit-malet) said : #4

Hello !

The error comes from the fact that your directory contains a space character. Please use one-word names for directories and everything should be fine.

Regards,
Benoît

Esa-Petri (esapete) said : #5

Thanks Benoit Malet, that solved my question.

Esa-Petri (esapete) said : #6

how do I solve thiss:
kdevelop: error while loading shared libraries: libkdevshell.so.0: cannot open shared object file: No such file or directory

Esa-Petri (esapete) said : #7

I reinstalled and problem vanished sorry to distrubt

Esa-Petri (esapete) said : #8

This eror I gained when building project in kdevelop and I have autoconf 2.61-3:
cd '/home/esa-petri/Ohjelmointi/projektit/firstest' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" make -f Makefile.cvs && cd '/home/esa-petri/Ohjelmointi/projektit/firstest/debug' && CXXFLAGS="-O0 -g3" "/home/esa-petri/Ohjelmointi/projektit/firstest/configure" --enable-debug=full && cd '/home/esa-petri/Ohjelmointi/projektit/firstest/debug' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" make -k
This Makefile is only for the CVS repository
This will be deleted before making the distribution

./admin/cvs.sh: 651: --version: not found
*** AUTOCONF NOT FOUND!.
*** KDE requires autoconf 2.53 or newer
make[1]: *** [cvs] Virhe 1
make: *** [all] Virhe 2
*** Exited with status: 2 ***

sorry for gainig thease proplems

Esa-Petri (esapete) said : #9

when I run autoconf I gain:
esa-petri@GOD-IS-laptop:~$ autoconf
autoconf: configure.in: No such file or directory

Esa-Petri (esapete) said : #10

I think I found a bug if autoconf2.13 and newer version is both installed, newer autoconf won't work

Esa-Petri (esapete) said : #11

once again problem went away. Now by removing autoconf2.13.

Ido (barkanido) said : #12

hi guys,

i have the same problem (i think). hello world build throws me this:

cd '/home/ido/d' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" make -f Makefile.cvs && mkdir '/home/ido/d/debug' && cd '/home/ido/d/debug' && CFLAGS="-O0 -g3 " "/home/ido/d/configure" --enable-debug=full && cd '/home/ido/d/debug' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" make -k
aclocal
configure.in:8: warning: macro `AM_PROG_LIBTOOL' not found in library
autoheader
automake
autoconf
configure.in:8: error: possibly undefined macro: AM_PROG_LIBTOOL If this token and others are legitimate, please use m4_pattern_allow. See the Autoconf documentation.
make: *** [all] Error 1
*** Exited with status: 2 ***

I already have the latest build-essential package.
can anyone help?
thanks.

Esa-Petri (esapete) said : #13

try reinstall build-essential and check that autoheader, automake, autoheader is installed

sandrog (svg-tele2) said : #14

I am trying to build example projects with "Kdevelp->Multilanguage IDE- New project - Python template" for building Python-GTK applications but the menu-debug is always empty. Under "Project -> Project-Options" I don't see any options or something else to activate the debug function. This functionality is essential to develop programs in any
programming-language.

I have the following env.
Kubuntu 8.04
KDE 3.5.10
Kdevelop 3.5.3
gdb,gdb-doc,libgdbm3, python-gdbm installed

Please do you have any suggestion ??

thanks in advance
Sandro