opengl documentation

Asked by Craig Vyvial on 2007-04-27

How do i get the Opengl Documentation in KDevelop to work correctly so i can view all the GL Functions from the toc file.

I keep getting errors like this..

An error occurred while loading man:glAccum:
Could not start process Unable to create io-slave:
 klauncher said: Unknown protocol 'man'.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu kdevelop Edit question
Assignee:
No assignee Edit question
Last query:
2007-04-29
Last reply:
2007-04-30
Cesare Tirabassi (norsetto) said : #1

Can I ask you what OpenGL documentation and how you installed it in your PC and kdevelop?

Craig Vyvial (cp16net) said : #2

I just installed Ubuntu 7.03 to check it out and i installed KDevelop with synaptic package manager and everything runs fine but the opengl documentation file that was installed with KDevelop gives me the error above in the main display window.

From my analysis i think it could be something with the opengl.toc file not being read properly or something because i tried the other documentation files work in the list and they worked fine. But i am not sure why the documentation is calling man for the opengl doc.

I have been doing some opengl development and i was curious on how helpful that documentation maybe.

Cesare Tirabassi (norsetto) said : #3

If the opengl doc is a man entry then it makes sense that man (actually the konqueror man extension) is called.
You can try to check the associated toc file. It should be located in:

/usr/share/apps/kdevdocumentation/tocs/opengl.toc

You can find a basic description of the toc file format in:

http://docs.kde.org/development/en/kdevelop/kdevelop/setup-docu.html

You can also try to open the Opengl man doc with Konqueror, to check that it is indeed displayed correctly.

Can you help with this problem?

Provide an answer of your own, or ask Craig Vyvial for more information if necessary.

To post a message you must log in.