KDevelop : You need to select a cmake binary

Asked by Kim Lyon on 2010-03-08

I am in the process of porting an application onto Linux . I initially set the project up in Code::Blocks and this went well - it is compiling ok. .

The application requires a GUI and I have settled on the KDE GUI in the first instance . As such I have installed the KDevelop - K Desktop Environment Version 4.3.2 (KDE 4.3.2) . When I create the project :-

KDE 4 GUI Application

it comes back with :

You need to select a cmake binary

it doesn't tell me what a cmake binary is - is this the output file name ? It doesn't display a choice . The help pages are missing . ( And when I cancel the dialog the KDevelop crashes . )

I want to keep things as simple as possible and if I can do it all in Code::Blocks that would be even better .

Any Ideas ?

Many Thanks

Kim Lyon

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu kdevelop Edit question
Assignee:
No assignee Edit question
Solved by:
Kim Lyon
Solved:
2010-03-08
Last query:
2010-03-08
Last reply:
2010-03-08

Have you installed cmake?

sudo apt-get nistall cmake build-essential

Should do it.

Kim Lyon (kim-lyon) said : #2

Many Thanks for getting back to me . That works .

I had assumed that KDevelop would install everything that it required - even as a default . However obviously not . The documentation , unfortunately , is very lacking .

Submit a bug stating that kdevelop doesn't install what it needs. It will hopefully get resolved.

Lawrence F Permenter (p1310) said : #4

Kubuntu .10: Wed 19 OCT 2011. KDevelop : "You need to select a cmake binary": still exists as a problem for Kdevelop 4.7.1.

please open this problem again. thanks.
LFP

Lawrence F Permenter (p1310) said : #5

oops: I should have said

Kubuntu .10: Wed 19 OCT 2011. KDevelop : "You need to select a cmake binary": still exists as a problem for KDE Development Platform 4.7.1 and KDevelop 4.2.3.

please open this problem again. thanks.
LFP