How do I keep printline from wandering all over the place?

Asked by Ken Johnson on 2009-06-23

I am plagued with the printline and cursor wandering all over the place as I type. It is like pushing a wet noodle I really get riled because of the errors this problem causes me.

Is there anything that can be done to stop/correct this problem?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu kdeutils Edit question
Assignee:
No assignee Edit question
Solved by:
Ken Johnson
Solved:
2009-06-25
Last query:
2009-06-25
Last reply:
2009-06-23
pablitofuerte (pablitofuerte) said : #1

Do you mean that you touch your touchpad while writing with a laptop?
If this is the case, have you got an usb-mouse?

Ken Johnson (pebmich-comcast) said : #2

I use a usb mouse and do not touch my touchpad unless circumstances dictate

pablitofuerte (pablitofuerte) said : #3

Ok, you can disable your touchpad (so it will not bother you while writing) if you already use an usb-mouse.
Go to System - Mouse . Then Touchpad tab, uncheck Activate Touchpad.

There is also a trick to disable the touchpad when a usb mouse is inserted but it needs to do some xorg.conf modifications
sudo gedit /etc/X11/xorg.conf

You got to locate in xorg.conf the section:
Section "InputDevice"
Identifier "Touchpad"
EndSection

if we add this line at the end of section
Section "InputDevice"
Identifier "Touchpad"
...
Option "SHMConfig" "on"
EndSection

and we make a file "/etc/udev/rules.d/01-touchpad.rules"
in which are wrote:
ACTION=="add", SUBSYSTEM=="input", ID_CLASS="mouse", RUN+="/usr/bin/synclient TouchpadOff=1"
ACTION=="remove", SUBSYSTEM=="input", ID_CLASS="mouse", RUN+="/usr/bin/synclient TouchpadOff=0"

and restart X, every time you connect a usb mouse it disable the touchpad and when disconnect usb mouse it enable touchpad

Ken Johnson (pebmich-comcast) said : #4

Pablito,
ourumps all over the place --- this is the problem. answer but the mouse is not the problem. Look at the typing on this page and how it j
Thank you for y

(Pablito, The above typing is a good example of what I am complaining about, jumbled-up, disorganized, irregular printing. The mouse is not the problem. It is like pushing a wet noodle as I type, the cursor on the print line has a mind of its own.

Ken Johnson (pebmich-comcast) said : #5

P.S. I disabled the touchpad in System.

pablitofuerte (pablitofuerte) said : #6

With my crappy english and your "jumbled-up, disorganized, irregular printing", I don't understand a word.
What I am trying to say is that: While writting , if you touch the touchpad with the bottom -palm- of your hand, that provokes exactly that kind of behavior (you're describing) in the cursor.
So I am propossing to disable the Touchpad, so it does'nt interfiers-affects while you are writting. If you are already using a usb-mouse, the touchpad is useless so you can disable. (INSTRUCTIONS ABOVE)
Of course you can enable/disable at will, but you will need the mouse to do it.
Hope that helps

Ken Johnson (pebmich-comcast) said : #7

Pablito,

 This problem arises only in Linux and has yet never been encountered in Windows.

 The touchpad has been disabled and does not work.It was disabled six months ago when I bought this computer. I do not touch the launchpad with the palm of my hand. The tip of my fingers is all that touches the computer keyboard as I type. Therefore, the touchpad is not the problem, something else is

Can you help me any further?

Pablito, your English is good. That first paragraph is a good example of what I am trying to say about my problem with the cursor jumping all over the place --- I speak and type better English than that! (heh!)

Ken Johnson (pebmich-comcast) said : #8

Will close this out until next time ...