cannot mount dvd properly

Asked by Franco Melis on 2008-03-01

OS Kubuntu 7.10 AMD64 installed as unique OS on "MB ASUS V£-M2V890 + AMD Athlon 64x2 Dual core 5200+HDD Maxtor STM332082+Burner Pioneer DVR 112-D". Burner worked properly both as cd reader, burner and dvd reader, burner until two days ago when, suddenly, dvd functionality failed in both reading and burning. It still remains cd ROM functionality but not writing. In system configuration when asked to the system to abilify the cd/dvd returns: Return code from mount was 32. "mount failure". I tried to reinstall previous situation without success.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu kdeutils Edit question
Assignee:
No assignee Edit question
Last query:
2008-03-05
Last reply:
2008-03-16
Urbán Dániel (urban.dani) said : #1

Please try to mount manually, with the mount command in a terminal. For example, if your DVD writer device is /dev/scd0 (and there is a DVD in the drive), type "mount /dev/scd0".
With this command you probably get a more detailed error message, and we may be able to find out what is the problem.

Franco Melis (franco-melis) said : #2

~# mount /dev/hdc
mount: dispositivo a blocchi /dev/hdc è protetto da scrittura, viene montato in sola lettura
mount: wrong fs type, bad option, bad superblock on /dev/hdc,
       missing codepage or helper program, or other error
       In alcuni casi si possono trovare informazioni utili in syslog. Provare
       ad esempio 'dmesg | tail'
This is the message obtained by typing your suggestion in a terminal.
Thank you in advance for your support.

Urbán Dániel (urban.dani) said : #3

Please try, what it said: "dmesg|tail" (this will contain the kernel messages, and maybe it contains something related to the problem).
(Are you sure, that /dev/hdc is the DVD drive?)

Franco Melis (franco-melis) said : #4

actually I also noted /dev/hdc was not usual for dvd drive but that is the path selected automatically by the system to mount cd.
dsmeg/tail reported:
[ 354.443721] end_request: I/O error, dev hdc, sector 1024
[ 354.443787] hdc: tray open
[ 354.445675] hdc: error code: 0x70 sense_key: 0x02 asc: 0x30 ascq: 0x00
[ 354.445677] end_request: I/O error, dev hdc, sector 1028
[ 354.445948] hdc: tray open
[ 354.446074] hdc: error code: 0x70 sense_key: 0x02 asc: 0x30 ascq: 0x00
[ 354.446076] end_request: I/O error, dev hdc, sector 1024
[ 354.446144] hdc: tray open
[ 354.448357] hdc: error code: 0x70 sense_key: 0x02 asc: 0x30 ascq: 0x00
[ 354.448360] end_request: I/O error, dev hdc, sector 1028

any suggestion?

Urbán Dániel (urban.dani) said : #5

Strange...
Maybe try dmesg | tail -n 20 (this means, that the last 20 lines, not just 10), right after you put in the DVD. And then right after you tried to mount.
Are you say, that with CD this drive work well?
Before this problem started, have you installed updates/softwares?

Sincerely, I'm running out of ideas... sorry, but I really don't have much idea, what could be the problem...

(One last idea: check with another OS, maybe a live CD, or something like that.)

Kevin (kevinrs91) said : #6

try restarting the computer

Can you help with this problem?

Provide an answer of your own, or ask Franco Melis for more information if necessary.

To post a message you must log in.