Ubuntu

Kate FTP Connection Error

Asked by Jeffery on 2009-12-13

I use Kate (KDE Advanced Text Editor) to edit the files on my website, and I generally use the built-in FTP connection in the Filesystem Browser. It's really easy...I enter ftp://<email address hidden>. It then prompts me for a password. After entering my password, all my files are shown in the Filesystem Browser. Everything worked great under Ubuntu 9.04.

When I upgraded to Ubuntu 9.10 (using the auto-update), the FTP functionality in Kate seems to have been broken. I have tried everything that I know to do. I have removed Kate and KDE and re-installed them. Same problem. I downloaded Ubuntu 9.10 and installed it in VirtualBox, installed Kate, but I have the same problem.

Here is the exact error reported in Kate: "Could not connect to host mywebsite.com: Timed out trying to connect to remote host."

One workaround is to use FileZilla to download the files, edit them in Kate, and then upload the files back to the website. That's fine, but a lot of my edits are quick and dirty, so editing the files directly on the website is my preferred method. Another workaround is to use JEdit. I tried the same thing in JEdit (with the FTP plugin), and it works fine. I like JEdit, but I prefer Kate and would like to get it working.

Could I be missing a FTP plugin or setting for Kate? Please help! Thanks.

Kate Version 3.3.2, Using KDE 4.3.2

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu kdesdk Edit question
Assignee:
No assignee Edit question
Solved by:
Jeffery
Solved:
2009-12-23
Last query:
2009-12-23
Last reply:
2009-12-15

Why not just mount the FTP. It will then appear as a local folder on your system which Kate can easily edit.

Jeffery (jeffery-barron) said : #2

Mounting the FTP location is an interesting suggestion, but I've had trouble with that in the past. Meanwhile, my biggest concern is that the functionality that I described above in Kate worked in Ubuntu 9.04 prior to my upgrade, but it does not work in Ubuntu 9.10 (in my current configuration).

Any other thoughts?

Log a bug then. It may get fixed or reinstated if the functionality has been removed.

Jeffery (jeffery-barron) said : #4

Thanks for the feedback. I created a bug and gave information about the version Kate that worked in Ubuntu 9.04 and the version of Kate the is not working in Ubuntu 9.10. I reconfirmed that the FTP functionality is working in 9.04 by installing a clean version in VirtualBox.

Jeffery (jeffery-barron) said : #5

The FTP connection error was related to a network configuration problem in Ubuntu 9.10 (see bug 417757, now linked). I was able to change my network settings and fix several problems all at once, e.g., faster internet browsing (in Firefox and Chrome) and Kate doesn't time out when trying to connect to an FTP site.

Instructions for changing the network settings to OpenDNS can be found here: https://store.opendns.com/setup/device/ubuntu/.

This solved my problem.