kalarm installed but blank New Display Alarm window

Asked by JiGong on 2009-09-28

New to Linux. Using Ubuntu 9.04 kernel linux 2.6.28-15-generic GNOME 2.26.1
Installed KAlarm 2.1.6 using KDE 4.2.2, but if KDE itself is installed on my machine, I can't tell. Searching kde on add/remove aps shows a few odd items checked, but nothing sounding that basic.
KAlarm appears to work just fine, BUT I can't set alarms b/c the New Display Alarm window is totally blank. (Ditto, New Command Alarm & New Email Alarm; New from Template does nothing.) Neither can I find the KAlarm Handbook b/c that tells me "Could not launch the KDE Help Center: Could not find service 'khelpcenter'."
Thanks for any help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu kdepim Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2009-10-05
Last query:
2009-10-05
Last reply:
2009-10-04
Sam_ (and-sam) said : #1

Seems kde libs are missing.
Unfortunately Add/Remove isn't very advanced, so you may use Synaptic where it will install dependencies.
https://help.ubuntu.com/community/SynapticHowto

Search for 'kdebase', kdelibs', 'kdepim'
or with 'KAlarm' you can view dependencies in properties.

Option CLI.
To see dependencies in a terminal type:
aptitude show kalarm

https://help.ubuntu.com/community/AptGet/Howto
https://help.ubuntu.com/community/UsingTheTerminal

JiGong (bobk) said : #2

Looks like that ought to work, and thank you, but I have not had success.
I did the search for kdebase etc. under Synaptic, and installed lots that came up. No luck. Then I visited the website for Kalarm and was told that it required the kde base. Installed that, got lots of interesting programs that work very well, but not my KAlarm. I reinstalled, uninstalled, reinstalled. With Synaptic. No luck. So I went to properties under Synaptic and laboriously checked each dependent item. Maybe one was missing at first. Did that, but now all are installed for sure, and still no luck. If I go to remove kalarm under applictions add/remove, I get a refusal because other programs are tied to it. Any other ideas?

Best Sam_ (and-sam) said : #3

When you start KAlarm in a terminal like this:
kalarm

are there some errors as discribed here:
https://bugs.launchpad.net/ubuntu/+source/kdepim/+bug/370526

When I had KAlarm (years ago) there was no problem with uninstalling concerning dependencies, but I don't use Add/Remove.
However, even something else gets uninstalled it can be reinstalled. Synaptic also offers to view history and it can be double checked here:
http://packages.ubuntu.com/jaunty/kalarm

https://help.ubuntu.com/community/UsingTheTerminal

http://www.astrojar.org.uk/kalarm/changelog.html

philrange (philrange) said : #4

I had the same problem, although it wasn't always blank, only about 75% of the time.

If it is blank, I found maximising the window makes everything appear.

JiGong (bobk) said : #5

Thanks Sam, that solved my question.