korganizer :: Cannot change the week start day to Sunday

Asked by stevebj on 2007-05-26

Using KDE 3.5.6, korganizer 3.5.6, I have not been able to change the week to start with Sunday. Instead, it starts on Monday (which was the dafault).

I configured this on a debian etch installation last week...and it worked by simply going to 'Settings-->Configure Date and Time'

With ubuntu, doing this does not open the window for configuration.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu kdepim Edit question
Assignee:
No assignee Edit question
Solved by:
stevebj
Solved:
2007-05-27
Last query:
2007-05-27
Last reply:
2007-05-27
Ralph Janke (txwikinger) said : #1

Thanks for the question.

I have no no problem opening this window. You can also try it by opening KMenu->System Settings then Personal->Region and Language In the left column Country/Region and Language and then the tab Time & Dates. Change First Day of week. Appky the changes.

You have to restart Korganizer that it will be reflected

I hope this helps

Best stevebj (stevebj-ee) said : #2

I installed khelp* and kcontrol* today...then the configuration window that allowed me to change the settings appeared.

atlantique (atlantique) said : #3

-- I have no no problem opening this window. You can also try it
-- by opening
--
-- KMenu->System Settings then Personal->Region and Language
--
-- In the left column Country/Region and Language and then the tab
-- Time & Dates. Change First Day of week. Appky the changes.

   I use korganizer under gnome (2.20.1) and sometimes I need to
   have my weeks start on Sunday, rather than with the default Monday.
   And for a long time I have been unable to use the korganizer graphical
   interface to do

       [Settings] --> [Configure Date and Time]

   because no window opened, and nothing happened. Nothing except
   for the following message in the shell from where korganizer
   was started:

      kcmshell (kdelibs): WARNING: Could not find module 'language'

   Given that I was not running KDE the suggestion of using the KDE menu
   to change "Region and Language" was of no use. But installing
   "kcontrol" magically my solved my problem. And I did not have
   to run or install kde. A window opnened and I was able
   to change "First day of the week". Many thanks stevebj!!

   For me Korganizer is irreplaceable, since I do not know of any
   alternative programs having such a practical command line tool
   as kconsolekalendar.

   Thanks again!

   Lisa.

Alan Porter (alan.porter) said : #4

Or you can edit $HOME/.kde/share/config/kdeglobals and add this:

[Locale]
Country=C
Language=en_US
PositiveSign=
TimeFormat=%l:%M:%S %p
WeekStartDay=7