can't find a norwegian translation

Asked by Bjørn Håkon Mathisen on 2007-05-18

I'm running Ubuntu 7.04 with Gnome. I prefer Gnome over KDE. However, I rather like Kontact, which is a KDE application. It works like a charm, but I only get the English version. I see that it is almost 100% translated into Norwegian, but I can't find a way to get the Norwegian version. There should be one or several Norwegian language files or what? I have no clue.
How can I get Kontact in Norwegian?
Thank you very much for your time and help.
Kind regards,
Bjorn Hakon Mathisen

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu kdepim Edit question
Assignee:
No assignee Edit question
Solved by:
Thomas Templin
Solved:
2007-05-19
Last query:
2007-05-19
Last reply:
2007-05-18
Best Thomas Templin (coastgnu) said : #1

On Fri, 18. May 2007 23:29:19 Bjørn Håkon Mathisen wrote:
> New question #6826 on kdepim in ubuntu:
> https://answers.launchpad.net/ubuntu/+source/kdepim/+question/6826
>
> I'm running Ubuntu 7.04 with Gnome. I prefer Gnome over KDE. However, I
> rather like Kontact, which is a KDE application. It works like a charm, but
> I only get the English version. I see that it is almost 100% translated
> into Norwegian, but I can't find a way to get the Norwegian version. There
> should be one or several Norwegian language files or what? I have no clue.
> How can I get Kontact in Norwegian?
> Thank you very much for your time and help.
> Kind regards,
> Bjorn Hakon Mathisen

Hi Håkon
There might be two reasons.
1. you didn't enable no lang-pack in kcontrol.
2. you don't have installed the no lang-pack for KDE

Check out if you've installed the no language pack for KDE:
 sudo apt-get -s install language-pack-kde-no
Or
 sudo apt-get -s install language-pack-kde-nb

And after this you have to start kcontrol and put the no / nb lang-pack in the
first place:
You will find it in kcontroll just below KDE-Components in:
 'regional settings' - 'country/region & language'

And there are also nb and no lang-packs for Gnome
language-pack-gnome-nb
language-pack-gnome-no

regards,
thomas

The problem was indeed the KDE language packs. I wasn't able to fix it by installing the language packs, so I installed the KDE desktop. This didn't fix it, either, and it cluttered up my menues with both Gnome- and KDE applications. This is a well known issue, and doesn't really bother me much. In the end, I decided that as I had just installed Ubuntu and there was nothing to lose, I would reinstall Ubuntu. This time, I installed Ubuntu, the automatic updates and then KDE. After a reboot (I've probably been using Windows for too long :-) ), I enabled file sharing. Now, I got a dialogue box that said that the KDE language packs were not completely installed. There was an option to fix it, and I did. Now, Kontact came up in Norwegian, no problem. And, my menues are not cluttered because I have not started a KDE-session yet.
Thanks for your help!