Kontact window covers a whole desktop view -- can't resize, minimize nor move the window

Asked by fred99 on 2009-02-22

When I start Kontact, the window covers a whole desktop.

Kontact itself is fully usable. It is also possible to me to start applications on the same desktop as kontact using shortcuts but I don't have the bottom panel to easily switch between applications.

I tried to resize, move and minimize the kontact window by using the shortcuts (alt-F7, and so on) without succeeding. It is not possible to use the usual "minimize", "maximize" and "close" button since they aren't shown. It is on the other hand possible to close kontact using alt-F4.

Any ideas how to control the size of my kontact window?

/Fred
---
Ubuntu, Intrepid Ibex 8.10

$ uname -a
Linux fd-laptop 2.6.27-11-generic #1 SMP Thu Jan 29 19:24:39 UTC 2009 i686 GNU/Linux

$ dpkg -s kontact
Package: kontact
Status: install ok installed
Priority: optional
Section: kde
Installed-Size: 1660
Architecture: i386
Source: kdepim
Version: 4:4.1.4-0ubuntu1~intrepid2
Replaces: kontact-kde4
Depends: kdebase-runtime (>= 4:4.1.3), kdelibs5 (>= 4:4.1.4), kdepimlibs5 (>= 4:4.1.4), korganizer, libc6 (>= 2.4), libkdepim4, libkholidays4, libqt4-dbus (>= 4.4.3), libqt4-qt3support (>= 4.4.3), libqtcore4 (>= 4.4.3), libqtgui4 (>= 4.4.3), libstdc++6 (>= 4.2.1)
Recommends: kmail, knotes
Suggests: akregator, knewsticker, kweather, gnokii, kitchensync, knode
Conflicts: kontact-kde4

Edit: " I don't even see the menus at the top (File, Edit, View,...)." I actually can see those menus.
Edit2: Removed the e-mail of the maintainer of the package to avoid spam-scanning...

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu kdepim Edit question
Assignee:
No assignee Edit question
Solved by:
fred99
Solved:
2009-02-26
Last query:
2009-02-26
Last reply:
2009-02-22
fred99 (fred99) said : #1

Found this post related to my question.

https://answers.launchpad.net/ubuntu/+source/kdepim/+question/61586

/Fred

Tom (tom6) said : #2

Perhaps you could report this as a bug? It's best done from inside Kontact if possible. Just use the option in the "Help" menu to "Report a bug/problem", that then sends some basic info about packages you have installed and stuff like that - not personal data - to the bug-squad. If you can link this question to the bug that would be great or just posting the number of your bug-report back to in here would be superb.

Thanks in advance and regards from
Tom :)

PS do you have to keep changing resolution size in order to deal with this? Does Alt help you grab and move the title bar way above the visible screen?

fred99 (fred99) said : #3

Hi Tom,

Thanks for your quick reply!

> Perhaps you could report this as a bug? It's best done from inside Kontact if possible. Just use the option in the "Help"
> menu to "Report a bug/problem", that then sends some basic info about packages you have installed and stuff like
> that - not personal data - to the bug-squad.

I was just about to fill a bug when I found the following bug, which I believe is pretty much what I am experiencing:

https://bugs.kde.org/show_bug.cgi?id=183870

> Does Alt help you grab and move the title bar way above the visible screen?

No, it doesn't.

I will keep this question open until the above bug or any other solution fixes my problem.

Thanks again, Tom, for your involvement in this matter.

Best regards,
/Fred

Tom (tom6) said : #4

Ahhh, using the bug-report tool from the "Help" menu would help report it in launchpad bug-squad and that would help them over there too with the additional info no doubt.

Sorry to hear those work-arounds didn't help :(

Thanks and regards from
Tom :)

fred99 (fred99) said : #5

> Ahhh, using the bug-report tool from the "Help" menu would help report it in launchpad bug-squad and that would
> help them over there too with the additional info no doubt.

It was not simple to use the bug-report tool. "Could not find service 'kfmclient'." Unfortunately no easy "apt-get install kfmclient" available ('apt-cache search kfm' gives no hits either). I guess I'll have to do report my bug manually -- if of course you have a workaround even on this part ;-)

I will anyway put a note on my kontact ToDo-list to make sure I don't forget submitting the bug :-)

Thanks!
/Fred

fred99 (fred99) said : #6

I continued my quest for an answer in the following "Answers":

https://answers.launchpad.net/ubuntu/+source/kdepim/+question/61586

I ended up answering that question myself after I found the necessary links... Although I posted the answer in the above link, I also do it here:

Uncheck the checkbox located at:
System -> Preferences -> CompizConfig Settings Manager -> Utility -> Workarounds -> Legacy Fullscreen Support

If someone reads this post and the proposed workaround is not helping, just follow the link above. This should at least lead you to the right place to look at.

Cheers!
/Fred

Tom (tom6) said : #7

Brilliant, nicely found and fixed!! Congrats!
Also thanks for posting the answer back here. It all helps a lot and is much appreciated, thaknks :)

Good luck and regards from
Tom :)