KMail: How to get rid of fullscreen mode?

Asked by Martin Weigele on 2009-02-19

Hi, I am using kontact including kmail on top of ubuntu. After recent updates, it seems that kontact / kmail starts in full screen mode. However, I have found no way to get out of this full screen mode. Neither F11 nor ESC seems to work. Where is the switch?
Thanks.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu kdepim Edit question
Assignee:
No assignee Edit question
Last query:
2009-02-26
Last reply:
2009-04-01
fred99 (fred99) said : #1

Since like we have the same problem:

https://answers.launchpad.net/ubuntu/+source/kdepim/+question/61953

(Don't know how to properly link to my question nor how to add this comment without "Adding Answer" or "Adding Information Request...).

/Fred

I found out that the problem disappears after "tampering" with the screen resolution application (with a second screen attached to my laptop).

So it is likely that the problem resulted from an error left over from an earlier dual head configuration.

Now everything seems to work fine again.

fred99 (fred99) said : #3

Hi Martin,

> I found out that the problem disappears after "tampering" with the screen resolution application (with a second
> screen attached to my laptop).
>
> So it is likely that the problem resulted from an error left over from an earlier dual head configuration.

I'm glad to see there is hope! However, I believe that it will not help me to solve my problem since I have never used any dual head configuration. So the "left over" part of the root cause you provided simply can't apply to me.

Since this question is solved, I will pursue my quest for fix through the link I provided above.

Thanks for posting.

/Fred

Hi Fred,

you may want to try re-setting the screen resolution (setting back to some other resolution and forth to your original resolution).

Martin

fred99 (fred99) said : #5

Hello Martin,

Screen resolution seems to be closely related to the issue... When I switch from 1280 X 800 to 1024 X 768, it kills my X -- but this is another story ;-) -- and when I log back, the "full screen force mode" of Kontact is gone.

The battle was on the other hand half-won. When I switched back to 1280 X 800, the problem returned. I could of course use a 1024 X 768 screen resolution, but I look so much fatter on my last vacation pictures when using this resolution. This implies that I might have to live with the "full screen force mode" for (hopefully a little) while.

I really appreciate the time you're taking to help me figure this out.

/Fred

Hello Fred,

this morning after reboot, the problem has come back, so it is not solved.

fred99 (fred99) said : #7

> this morning after reboot, the problem has come back, so it is not solved.

I'm very sorry to hear that. This _was_ my hope.But I've got new hope! Read along.

This morning, I installed kontact on my computer at work. I'm running the exact same ubuntu -- intrepid ibex 8.10. After starting kontact, I was puzzled when I noticed that I was not getting an automatic full screen view. The question is: what is the difference between my personal computer and my job computer?

Both computers are laptops. But my job computer is in a docking station that I never pull out. This means that the screen I use at work is not 16:10 but rather 4:3. And that is the difference. Remember what I wrote yesterday?

> When I switch from 1280 X 800 to 1024 X 768 [...] and I log back, the "full screen force mode" of Kontact is
> gone.

This would mean that 1024 X 768 (a 4:3 display) was at a certain point working fine with kontact.

Could it be so that kontact can't manage a 16:10 display?

/Fred

fred99 (fred99) said : #8

Great news, Martin (and all googlers who's found this post!).

From your bug report:

https://bugs.launchpad.net/ubuntu/+source/kdepim/+bug/334818

... I've got automatically linked to its duplicate:

https://bugs.launchpad.net/ubuntu/+source/kde4libs/+bug/324232

And this bug report suggested a workaround that fixes the problem (thanks to the post http://ubuntuforums.org/showthread.php?p=6608130), that is:

Uncheck the checkbox located at:
System -> Preferences -> CompizConfig Settings Manager -> Utility -> Workarounds -> Legacy Fullscreen Support

For those who can't find the "CompizConfig Settings Manager" menu, install it (sudo apt-get install compizconfig-settings-manager).

Thanks Martin for the good teamwork!

Regards,
/Fred

mwm1998 (mwm1998) said : #9

Excellent post. Works exactly as stated. Thanks
Blessings
Michael

Can you help with this problem?

Provide an answer of your own, or ask Martin Weigele for more information if necessary.

To post a message you must log in.