unable to import messages

Asked by Ripper on 2007-05-05

under File menu, the import messages feature has been deactivated

Question information

English Edit question
Ubuntu kdepim Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Massimo Forti (slackwarelife) said : #1

Thanks for your question, which kind of works are you doing.


Best Ripper (marshal-yung) said : #2

Hi, thanks for taking attention to my question.

I was actually trying to import my mailbox from Thunderbird to KMail. I finally got it solved after a few tinkering and googling.

Here's what I did:

1) Compact all my mail folders from within Thunderbird. I'm not sure what good this does, but it was highly recommended in a few articles I found through Google.
2) I downloaded the Perl script mozilla2kmail.pl. What this script does is converting mbox mail formats from Thunderbird into Mail directory formats used in KMail. I ran this script from within Terminal. mozilla2kmail would create a new directory called "mozilla.directory" and place all the Thunderbird emails into this new directory.
3) After doing so, I restarted KMail, and all my Thunderbird mails are listed in the folder "Mozilla" From within KMail, I reorganised my mail folders and renaming them. I'm sure the same can be done straight from the file explorer or Terminal, but I lack the knowledge of mbox and Mail directory concepts. And reorganising folders from within KMail is merely drag and drop.

So, I hope this solution could help out someone. I can't find much resources online. The main problem in my case is that, the File -> Import Messages menu is disabled (grayed out). KDE Help Center mentioned the "Import Messages" resides in the Tools menu, but it's not. Some articles mentioned about exporting from Thunderbird and importing into Evolution, then copy the folder structure from Evolution into KMail's directory. But probably due to my lack of understanding, I couldn't find any similarity in mail directory format between Evolution and KMail.

By the way, I'm running Ubunty Feisty Fawn + GNOME. I'm using Kontact (KDE PIM) as my PIM. I'm wondering if it's because I'm running Kontact under GNOME, that causes the "Import Message" menu to be disabled.

Anyway, thanks Massimo for helping out.