KAlarm Autostart at Login

Asked by Kevin Moulton on 2008-11-22

Hello,

I have installed KAlarm, and configured it to Autostart at Login, and run continuously in the system tray. I set these so that I would not have to remember to start KAlarm when I login, and would benefit from the alarms I have set. However, it doesn't work. When I login, KAlarm does not start, and my alarms are not displayed. Only when I manually start KAlarm does it display any alarms I've missed.

Am I doing something wrong?

Kevin

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu kdepim Edit question
Assignee:
No assignee Edit question
Last query:
2008-11-23
Last reply:
2015-07-10
Sam_ (and-sam) said : #1

Hi Kevin,
I guess you didn't add it to sessions (menu system -> preferences).

Kevin Moulton (kevinmoulton) said : #2

Sam,

Thanks. This does make KAlarm start when I login, but I can start any program at login that way. If that's what I need to do, then what is the purpose of the "autostart at login" setting in the configuration of KAlarm.

The problem with this sessions solution is that I want KAlarm to simply run in the system tray until it actually needs to display an alarm. When I run it with sessions, it loads as if I started it from the command line, and shows me all upcoming alarms. I'm looking for the "autostart at login" and "run continuously in system tray" settings to do exactly what they say.

Any thoughts?

Kevin

Sam_ (and-sam) said : #3

Hi,
autostart configuration is depending on the system, Gnome or KDE, Hardy or Intrepid, procedures are different.
Autostart and system tray are not equal and don't work together automatically with certain apps.

However, to have it in the system tray right away you may install 'alltray' with the package manager.

http://alltray.sourceforge.net/faq.html

Some general information
http://pim.kde.org/components/kalarm.php
http://www.astrojar.org.uk/kalarm/screenshots.html

https://help.ubuntu.com/community/KubuntuAutostart

John Hagerman (handj949) said : #4

Had the same problem in Ubuntu 14.04, fussed around for several hours, and finally decided to just use "Startup Applications". The command there is very simple - /user/bin/kalarm - and KAlarm fires up right after startup.

The only problem - for me - is it doesn't come up minimized and I can't figure out how to make it do that. Anybody know?

Can you help with this problem?

Provide an answer of your own, or ask Kevin Moulton for more information if necessary.

To post a message you must log in.