No Sound From Laptop's Internal Speakers

Asked by Krishna on 2009-12-23

There is no sound from Laptop's Internal Speakers in UBUNTU 9.04..
Perfectly ok when connecting External Speakers..
I don't have this problem while using Windows... Windows support both Internal And External Speakers...

I have collected many information regarding this problem..
I typed the following COMMANDS in Terminal And got respective OUTPUTS...
Please help me solve this problem...
Thank You...

MODEL: Compaq Presario CQ61
SPEAKERS: Built-in Altec Lansing Speakers

COMMAND: lspci

OUTPUT:(only Audio)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

COMMAND: grep "^Codec\|^Vendor Id\|^Subsystem Id\|^Revision Id" /proc/asound/card*/*codec*{,/*} | grep -B2 -A1 $(lspci -nv | grep -A1 0403 | grep Subsystem | sed 's/://g' | awk '{ print $2 }')

grep: /proc/asound/card*/*codec*/*: No such file or directory
/proc/asound/card0/codec#0:Codec: IDT 92HD75B2X5
/proc/asound/card0/codec#0:Vendor Id: 0x111d7608
/proc/asound/card0/codec#0:Subsystem Id: 0x103c3069
/proc/asound/card0/codec#0:Revision Id: 0x100202

COMMAND: cat /proc/asound/cards

 0 [Intel ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xd4500000 irq 22
COMMAND: lsmod | grep snd


snd_hda_intel 436148 3
snd_pcm_oss 46336 0
snd_mixer_oss 22656 1 snd_pcm_oss
snd_pcm 83076 2 snd_hda_intel,snd_pcm_oss
snd_seq_dummy 10756 0
snd_seq_oss 37760 0
snd_seq_midi 14336 0
snd_rawmidi 29696 1 snd_seq_midi
snd_seq_midi_event 15104 2 snd_seq_oss,snd_seq_midi
snd_seq 56880 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 29704 2 snd_pcm,snd_seq
snd_seq_device 14988 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 62756 15 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore 15200 1 snd
snd_page_alloc 16904 2 snd_hda_intel,snd_pcm

COMMAND: sudo aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
COMMAND: lspci -v | less

OUTPUT: (only Audio)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
        Subsystem: Hewlett-Packard Company Device 3069
        Flags: bus master, fast devsel, latency 0, IRQ 22
        Memory at d4500000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel


Question information

English Edit question
Ubuntu kdemultimedia Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Krishna (krishnab) said : #2

I have Upgraded Alsa to 1.0.19 and then to 1.0.20 and still No Sound From Internal Speakers..
Everything else is perfect.. PCM, speakers or Front, Master all Full Volume..

The problem is not that I can get a faint sound from Headphones..
When I connect woofer or headphones, with my present sound settings, sound gets extraordinarily amplified and really perfect sound...
Problem only with Built-in Speakers..

I had posed this first as a bug.. i got a reply that I need 9.10 to solve this problem..
I really like to stay with 9.04 and 9.10 doesn't support certain things...

Is there a way to solve this without moving to 9.10.....

Please read the last remark from Emilie in the URL link I gave you.

I will give you the link again:

Krishna (krishnab) said : #4

Sorry that this is late now.. Anyway the problem was solved already..

Now using Ubuntu 10.04 and has no problem related to the Internal Speakers...