Codec + Mixer: IDT 92HD71B7X - STAC92xx Analog Device - Audio Devices: ATI HDMI audio and IDT 92HD71B7X - Laptop HP DV5z AMD RV620 Audio-No Sound Speakers-Headphone Jack(s) Work in Kubuntu 9.04 64-bit edition

Asked by ElectronicCarpenter on 2009-05-17

The options intel hp... do not refer to my hardware so I did not try it. Here is the lspci and the mod probe of the alsa config for your reference..

I know I am missing something really simple.. But I am completely at a brain fart.

00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge
00:02.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (ext gfx port 0)
00:04.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 0)
00:05.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 1)
00:06.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 2)
00:0a.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 5)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [AHCImode]
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3a)
00:14.1 IDE interface: ATI Technologies Inc SB700/SB800 IDE Controller
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 11h HyperTransport Configuration (rev 40)
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 11h Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 11h DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 11h Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 11h Link Control
01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3400Series
01:00.1 Audio device: ATI Technologies Inc RV620 Audio device [Radeon HD 34xx Series]
08:00.0 Network controller: Atheros Communications Inc. AR928X Wireless NetworkAdapter (PCI-Express) (rev 01)
09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
0a:00.0 FireWire (IEEE 1394): JMicron Technologies, Inc. IEEE 1394 Host Controller
0a:00.1 System peripheral: JMicron Technologies, Inc. SD/MMC Host Controller
0a:00.2 SD Host controller: JMicron Technologies, Inc. Standard SD Host Controller
0a:00.3 System peripheral: JMicron Technologies, Inc. MS Host Controller
0a:00.4 System peripheral: JMicron Technologies, Inc. xD Host Controller

Here is the output for modprob.d alsa-base.conf

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu kdemultimedia Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2009-05-17
Last query:
2009-05-17
Last reply:
2009-05-17

Hi,

In order to gather essential troubleshooting information about your sound card, please first follow this procedure:

Step 1: Open Terminal from "Applications->Accessories->
Terminal"

Step 2: Run the following commands (copy/paste each command into the Terminal and then hit <enter>)

wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh

When the alsa-info.sh script asks "Do you want to run this script? [y/n]", press y and then hit <enter> to make sure the script actually runs. Please send us the full terminal output after the script has actually run.

Step 3: Run the following commands (copy/paste each command into the Terminal and then hit <enter>)

cat /proc/asound/cards
asoundconf list
sudo aptitude install gnome-alsamixer asoundconf-gtk
aplay -l
cat /dev/sndstat
lspci -nn
lsmod | grep snd
grep audio /etc/group

Step 4: Please post results (copy/paste terminal output from each command) on this thread

Step 5: Please also report on this thread if you cannot hear sound through the speakers, the headphones or cannot hear sound on both.

Step 6: Please also specify the exact model and make of your PC (if possible) on this thread

Step 7: If you are using a dual boot system (with Windows and Ubuntu installed on separate partitions),
then make sure to set the sound volume in Windows to a high level before booting into Ubuntu

Step 8: Experiment with the audio settings in gnome-alsamixer and asoundconf-gtk until you get sound (hopefully)

=======================================================================================

Please also read the following pages

http://www.ubuntugeek.com/sound-solutions-for-ubuntu-904-jaunty-users.html

http://doc.ubuntu-fr.org/audio_intel_hda (check for correct /etc/modprobe.d/alsa-base.conf options at bottom of this page)

https://help.ubuntu.com/community/SoundTroubleshooting

for some initial suggestions.

You should add the following 4 lines to the /etc/modprobe.d/alsa-base.conf file

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=hp-dv5
options snd-hda-intel enable_msi=1

Valid model names (that replace YOUR_MODEL) depending on the codec chip, can be found at

http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-jaunty.git;a=blob_plain;f=Documentation/sound/alsa/ALSA-Configuration.txt

If you do not know your codec chip name, you can execute the following Terminal command to find out:

cat /proc/asound/card*/codec* | grep Codec

Make sure to set all channels to high volume levels in gnome-alsamixer.

Make sure all the different speakers (including 'Front', 'Master', and 'PCM") are NOT muted and NOT set to low volume levels.

If the output of the command

grep audio /etc/group

looks like this:

audio:x:81

or like this:

audio:x:81:pulse

Then replace that audio line with something like this:

audio:x:81:<your login name>

where <your login name> is the username you use to log into Ubuntu

Kind regards,

Mark

Wow thanks for all the useful information.. Being logical I work from the top down so here are the specific results you requested Mark.

I am using Kubunu 9.04 fresh install with dual boot windows vista (both os 64 bit)
I will try the windows volume setting s first and continue working down the list you sent me.

Thank you for all you do for the free world..

pjvernon@dv5z-kbu64:~$ cat /proc/asound/cards
 0 [SB ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xd2400000 irq 16
 1 [HDMI ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xd2310000 irq 19

pjvernon@dv5z-kbu64:~$ asoundconf list
Names of available sound cards:
SB
HDMI

pjvernon@dv5z-kbu64:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root privileges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: STAC92xx Digital [STAC92xx Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

pjvernon@dv5z-kbu64:~$ cat /dev/sndstat
Sound Driver:3.8.1a-980706 (ALSA v1.0.18rc3 emulation code)
Kernel: Linux dv5z-kbu64 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64
Config options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
HDA ATI SB at 0xd2400000 irq 16
HDA ATI HDMI at 0xd2310000 irq 19

Audio devices:
0: STAC92xx Analog (DUPLEX)

Synth devices: NOT ENABLED IN CONFIG

Midi devices: NOT ENABLED IN CONFIG

Timers:
31: system timer

Mixers:
0: IDT 92HD71B7X
1: ATI ATI R6xx HDMI

pjvernon@dv5z-kbu64:~$ lspci -nn
00:00.0 Host bridge [0600]: Advanced Micro Devices [AMD] RS780 Host Bridge [1022:9600]
00:02.0 PCI bridge [0604]: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (ext gfx port 0) [1022:9603]
00:04.0 PCI bridge [0604]: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 0) [1022:9604]
00:05.0 PCI bridge [0604]: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 1) [1022:9605]
00:06.0 PCI bridge [0604]: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 2) [1022:9606]
00:0a.0 PCI bridge [0604]: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 5) [1022:9609]
00:11.0 SATA controller [0106]: ATI Technologies Inc SB700/SB800 SATA Controller [AHCI mode] [1002:4391]
00:12.0 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller [1002:4397]
00:12.1 USB Controller [0c03]: ATI Technologies Inc SB700 USB OHCI1 Controller [1002:4398]
00:12.2 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB EHCI Controller [1002:4396]
00:13.0 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller [1002:4397]
00:13.1 USB Controller [0c03]: ATI Technologies Inc SB700 USB OHCI1 Controller [1002:4398]
00:13.2 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB EHCI Controller [1002:4396]
00:14.0 SMBus [0c05]: ATI Technologies Inc SBx00 SMBus Controller [1002:4385] (rev 3a)
00:14.1 IDE interface [0101]: ATI Technologies Inc SB700/SB800 IDE Controller [1002:439c]
00:14.2 Audio device [0403]: ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383]
00:14.3 ISA bridge [0601]: ATI Technologies Inc SB700/SB800 LPC host controller [1002:439d]
00:14.4 PCI bridge [0604]: ATI Technologies Inc SBx00 PCI to PCI Bridge [1002:4384]
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] Family 11h HyperTransport Configuration [1022:1300] (rev 40)
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] Family 11h Address Map [1022:1301]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] Family 11h DRAM Controller [1022:1302]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] Family 11h Miscellaneous Control [1022:1303]
00:18.4 Host bridge [0600]: Advanced Micro Devices [AMD] Family 11h Link Control [1022:1304]
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Mobility Radeon HD 3400 Series [1002:95c4]
01:00.1 Audio device [0403]: ATI Technologies Inc RV620 Audio device [Radeon HD 34xx Series] [1002:aa28]
08:00.0 Network controller [0280]: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) [168c:002a] (rev 01)
09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 02)
0a:00.0 FireWire (IEEE 1394) [0c00]: JMicron Technologies, Inc. IEEE 1394 Host Controller [197b:2380]
0a:00.1 System peripheral [0880]: JMicron Technologies, Inc. SD/MMC Host Controller [197b:2382]
0a:00.2 SD Host controller [0805]: JMicron Technologies, Inc. Standard SD Host Controller [197b:2381]
0a:00.3 System peripheral [0880]: JMicron Technologies, Inc. MS Host Controller [197b:2383]
0a:00.4 System peripheral [0880]: JMicron Technologies, Inc. xD Host Controller [197b:2384]

pjvernon@dv5z-kbu64:~$ lsmod | grep snd
snd_hda_intel 557364 5
snd_pcm_oss 52352 0
snd_mixer_oss 24960 1 snd_pcm_oss
snd_pcm 99336 2 snd_hda_intel,snd_pcm_oss
snd_seq_dummy 11524 0
snd_seq_oss 41984 0
snd_seq_midi 15744 0
snd_rawmidi 33920 1 snd_seq_midi
snd_seq_midi_event 16512 2 snd_seq_oss,snd_seq_midi
snd_seq 66272 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 34064 2 snd_pcm,snd_seq
snd_seq_device 16276 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 78792 19 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore 16800 1 snd
snd_page_alloc 18704 2 snd_hda_intel,snd_pcm

pjvernon@dv5z-kbu64:~$ grep audio /etc/group
audio:x:29:pulse

Hi,

Please try this procedure:

a) Make sure to set all channels to high volume levels in gnome-alsamixer.
Make sure all the different speakers (including 'Front', 'Master', and 'PCM") are NOT muted and NOT set to low volume levels.

b) copy-paste the following commands into the Terminal:

wget http://www.linuxant.com/alsa-driver/alsa-driver-linuxant_1.0.19.2_all.deb
sudo dpkg -i alsa-driver-linuxant_1.0.19.2_all.deb
gksudo gedit /etc/modprobe.d/alsa-base.conf

c) and add these 6 lines to the end of the /etc/modprobe.d/alsa-base.conf file:

# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=dell-m4-1
options snd-hda-intel enable_msi=1

d) Then navigate to System>Preferences>Sound and change everything to ALSA

e) reboot and retest sound

f) if it does not work, replace the line

options snd-hda-intel model=dell-m4-1

with one of the following in /etc/modprobe.d/alsa-base.conf:

options snd-hda-intel model=dell-m4-2
options snd-hda-intel model=laptop
options snd-hda-intel model=hp-dv5

6. reboot and retest sound after changing to a different model in the alsa-base.conf file! So you might need to reboot up to 5 times if you want to try out all the different model options.

Regards,

Mark

Hi,

I did some more research and found this:

http://ubuntuforums.org/showthread.php?t=1139030

So I think that you need to use the following settings in /etc/modprobe.d/alsa-base.conf

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=hp-dv5
options snd-hda-intel enable_msi=1

Regards,

Mark

I use kde4 not gnome...
I used kate and added the lines requested. See below for the config file.
Now I have no sound . The headphones do not work now...
Any ideas? I am not using intel audio.. I tried that before...

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2

# Keep snd-pcsp from being loaded as first soundcard
 options snd-pcsp index=-2
 alias snd-card-0 snd-hda-intel
 alias sound-slot-0 snd-hda-intel
 options snd-hda-intel model=dell-m4-1
 options snd-hda-intel enable_msi=1

Hi,

Please read my previous remark:

"Hi,

I did some more research and found this:

http://ubuntuforums.org/showthread.php?t=1139030

So I think that you need to use the following settings in /etc/modprobe.d/alsa-base.conf

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=hp-dv5
options snd-hda-intel enable_msi=1

Regards,

Mark"

Thanks Mark ;)
I put the requested code back in the alsa-base.config and the headphone jack works now. I also installed gnome and checked to make sure it was using alsa and it is..

There is no sound in the internal speakers. I do not use intel audio as many of these laptops use. I use the RV625 from ATI I do not believe there is a driver for this configuration yet. I have been looking for a few weeks..

thanks for your help but I just think this is an unresolved issue.

PJ

In System/Adminstration/Users and Groups check that your users and root are members of the following groups

 pulse
 pulse-access
 pulse-rt

I added myself to these groups and now my speakers work..

Thanks Mark Problem Solved.

Thanks Mark Rijckenberg, that solved my question.

I don't have the
pulse-rt
available.
My audio doesn't work !!! I'm about to cry !!