kmix volume slider for usb-mic is stuck on "0"

Asked by yorick on 2009-04-29

Hi,

I've got a weird problem since I updated to Jaunty: I have a Logitech USB-Mic (AK5370), it is peoperly recognized, set as preferred input device and everything, but the respective volume slider in KMix is stuck on "0" and can't be moved! It's the same with the microphone for the USB-webcam.

Has anyone an idea how to grease that slider?!

Thanks in advance,

Yorick

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu kdemultimedia Edit question
Assignee:
No assignee Edit question
Last query:
2009-04-29
Last reply:
2009-06-02
passogiau (passogiau) said : #1

I have the same problem. It was working fine until this afternoon and I have not installed any new software

Allen Grush (a-grush) said : #2

I have the same problem also. I'll try a restart.
So far I have messed around in all the control panels and even set the master volume to be the same as the mic volume. nothing has worked so far.

Allen Grush (a-grush) said : #3

Well:
restarted ..no change:
unplugged the USB mic ... no change.
plugged in an old telex microphone ... no change
changed the settings in kmix, setting it to stereo mic, mic 1 and boosting the audio 20db above 100%, then selected the mic as "Capture". Got sound for about 5 minutes, then the output failed. Tried various output settings and got sound back for about 30 seconds when I switched to pulse audio. Muted Surround, Centre and LFE and got sound back.
except in SKYPE which tells me that there is a problem with sound output. I reset SKYPE to work with Pulse Audio and it now gives back the test sound,, dial tones, etc but when I try to make calls, it disconnects with the "problem with sound output" message. So I tried Audacity. I got no sound in or out, and the meters froze, then the program crashed. Tried Sound recorder. It seems to record the sound, but I only get pops and blips for playback.

Also, all the video and audio players shut down immediately after they start, no matter what format I try to load. I wonder if that is related. Hmmm.

I am running a clean install of Kubuntu 9.04 with Ubuntu Studio added. The computer is an old Dell Dimension 4600 P4 1.7 GHz processor, 1 gig ram, with INTEL ICH5 on board sound and an AC97 driver for ALSA. It kinda works .. sorta. Worked great in 8.04 once I figured out that the only sound output was through the headphone jack!

sure would appreciate some "sound" guidance!

Allen Grush (a-grush) said : #4

Oh yeah, the slider came unstuck when I unpluged the web cam and logged out and in.
guess the web cam will be used on one of the windows machines. Works good there.

I most likely forgot to mention something important. Please ask for specific information if you need it.

Thanks!

James Raymond (jamesmr) said : #5

I appear to have the same problem Allen Grush had, but I have been unable to solve mine.

Same mic, Kubuntu 9.04

I am confused.

Allen Grush (a-grush) said : #6

I thought I'd share a little of my curernt level of success with ya'll.

This may not be the right place for all of this, but I don't know where that right place would be. I am new here. Set me straight, If you can. I would like to conform to the customs of the forums. I just can't seem to find my way though the discussion tree to a place where people are talking about general system failure and the processes involved in slowly getting things to work. All the non-functioning parts seem to be intertwined, so just taking about how a particular piece of hardware or software is doing doesn't really pull the pieces together. Its kind of like one doctor treating the pain in someone's foot and another working on their ears to cure their vertigo when the problem is that they have a damaged nerve in their spine causing both problems, and no one is looking there.

I gave up on the usb mike for now. But I have reasonably good sound now and I finally got the camera to work.

Most stuff I use day to day works acceptably well now. Most of the time. There are unexplainable periods where the sound completely stops working in SKYPE for an hour or two, but then it just starts working again. It will work for several days just fine, then -- oops -- it goes out on strike again. Maybe it doesn't like the health plan or something.

So, I installed every video codec and driver I could find. I uninstalled SKYPE and replaced it with SKYPE Static (oss). I got the sound to work and the cpu to stay down except during a call. Video was still absent. The camera was found in all software, but there was no video coming in at all. I was using Cheese to check the webcam. Then I installed Ekiga. Suddenly the camera started working. It has also magically started working in Cheese, SKYPE, and several other programs too. I have no idea why. There must have been some missing library that Ekiga installed or something like that. I don't think the camera mike is working. I am using a Telex desk mike with a piece of acoustic foam suspended in front of it, but I have good sound and good video. The settings in Skype are

sound in: /dev/dsp/1
sound out: /dev/dsp/
ringing: /dev/dsp

The mike slider works good, and all my software starts and runs without just crashing, but some is not exactly working. Most of the system is using the hardware audio, INTEL ICH5, sometimes with alsa specified, sometimes not. Pulse Audio does not seem to work at all if I select it in any software program, but the system says it is still using it. Only SKYPE is using /dev/dsp/. Audacity runs the cpu to 100% (actually, xorg cpu load jumps to 70-80% when I hit record) and refuses to record. It will only playback a few seconds of pre-recorded audio and then just quits playing. Sound recorder works OK. Amarock works well. Video players are working great, but Kino crashes after playing 2 seconds of video with audio, but it has always been temperamental on this machine.. Text is scrolling smoothly for the most part. GIMP works great and so does Blender. All of OpenOffice is fine. Nautilis crashes or refuses to launch, but Dolphin works fine. Synaptic gets an A+. All the web browsers and their plug-ins work great. I have not tried most of the other software.

Anyhow, that is where it stands. The USB mike still doesn't work, so I'm not using it. It is plugged in again, but it doesn't even show up in the various pull downs nor in the mixer since I got SKYPE working. But, no real problem. I have found some work-arounds. Still fiddling with things to get the other stuff working. I will need Kino and Audacity to finish a project I started in Hardy, so I will continue to fiddle. I'm focusing on getting a usb SD-card reader to work reliably. I have two. Both work intermittently. They seem to corrupt the directories of the cards when I erase just a few of their files from them. Seems to work OK if I throw out everything at once.

Can you help with this problem?

Provide an answer of your own, or ask yorick for more information if necessary.

To post a message you must log in.