No sound through laptop speakers hda-intel audio

Asked by Alien221 on 2009-04-15

I can't get sound out the speakers on my laptop, I do have sound from the audio jack located on the side. I've tried several different things through forum searches for similar problems, but no success. Here's the output of aplay -l

card 0: Intel [HDA Intel], device 0: ALC880 Analog [ALC880 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC880 Digital [ALC880 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 6: Si3054 Modem [Si3054 Modem]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Under Sysinfo the Multimedia audio controller is stated as:

Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
Subsystem: Uniwill Computer Corp Device 9070

My laptop is an Alienware Area-51 m5750. Any help would be greatly appreciated as I'm going nuts trying to figure this out. I'm pretty new to Linux in general and this is the only major problem I've had so far.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu kdemultimedia Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2009-04-18
Last query:
2009-04-18
Last reply:
2009-04-15

Hi,

Please try this procedure:

1. copy-paste the following command into the Terminal:

gksudo gedit /etc/modprobe.d/alsa-base

2. and add these lines to the end of the file:

# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=3stack position_fix=1
options snd-hda-intel enable_msi=1

3. copy-paste the following command into the Terminal:

gksudo gedit /etc/modprobe.d/options

4. and add these lines to the end of the file:

# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=3stack position_fix=1
options snd-hda-intel enable_msi=1

5. Then navigate to System>Preferences>Sound and change everything to ALSA

6. reboot and retest sound after every change made to the alsa-base file

7. In the Mixer control panel, make sure to unmute all channels and increase the volume on all channels

8. If it still does not work, please try one of the following model options instead (replacing 3stack as model option):

 ALC880
   3stack 3-jack in back and a headphone out
   3stack-digout 3-jack in back, a HP out and a SPDIF out
   5stack 5-jack in back, 2-jack in front
   5stack-digout 5-jack in back, 2-jack in front, a SPDIF out
   6stack 6-jack in back, 2-jack in front
   6stack-digout 6-jack with a SPDIF out
   w810 3-jack
   z71v 3-jack (HP shared SPDIF)
   asus 3-jack (ASUS Mobo)
   asus-w1v ASUS W1V
   asus-dig ASUS with SPDIF out
   asus-dig2 ASUS with SPDIF out (using GPIO2)
   uniwill 3-jack
   fujitsu Fujitsu Laptops (Pi1536)
   F1734 2-jack
   lg LG laptop (m1 express dual)
   lg-lw LG LW20/LW25 laptop
   tcl TCL S700
   clevo Clevo laptops (m520G, m665n)
   medion Medion Rim 2150
   test for testing/debugging purpose, almost all controls can be
   adjusted. Appearing only when compiled with
   $CONFIG_SND_DEBUG=y
   auto auto-config reading BIOS (default)

Regards,

Mark

Alien221 (ericzombie) said : #2

Thank you very very much! This issue had been driving me nuts for the longest time. All I had to do was change 3stack to auto and it fixed it for me. Sorry it took a while to get back to you, it's been a busy week. This has saved me from a lot of frustration. Thank you for taking the time to help me, I really appreciate it!

Eric