no sound gatewat 3545gz laptop

Asked by max on 2008-12-04

i have just installed kubuntu 8.10 on my laptop (gateway 3545gz) everything runns well but i have no sound. i have tried some ideas i found in some forums to remove the alsa driver and reinstall it "fresh" but hasnt worked- the mixer i have tried to turn everything up but no soung- the media players i use seem to play but i hear nothing.- i dont have a problem with the hardware or settings because in windows it works well- i have also tried to build the alsa driver from source but i get errors and driver is not sucessfully installed. -
when i do $lspci -v this is what i get
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
        Subsystem: Rioworks Device 203e
        Flags: bus master, medium devsel, latency 0, IRQ 17
        I/O ports at 1c00 [size=256]
        I/O ports at 18c0 [size=64]
        Memory at e0100c00 (32-bit, non-prefetchable) [size=512]
        Memory at e0100800 (32-bit, non-prefetchable) [size=256]
        Capabilities: <access denied>
        Kernel driver in use: Intel ICH
        Kernel modules: snd-intel8x0
i saw in a forum and tried to add this line in /etc/modprobe.d/alsa-base
options snd-intel8x0 ac97_quirk=0

when building from source i do
max@maxiz:~$ sudo apt-get install build-essential linux headers-$(uname -r) module-assistant alsa-source
[sudo] password for max:
Reading package lists... Done
Building dependency tree
Reading state information... Done
build-essential is already the newest version.
E: Couldn't find package headers-2.6.27-9-generic

so am stuck any help?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu kdemultimedia Edit question
Assignee:
No assignee Edit question
Last query:
2008-12-04
Last reply:
2008-12-04

Hi,

This procedure might solve your issue:

https://answers.launchpad.net/ubuntu/+question/26837

If it is still not working, try turning up the volume on all channels in aumix and in alsamixer.

Regards,

Mark

Can you help with this problem?

Provide an answer of your own, or ask max for more information if necessary.

To post a message you must log in.