area code for playing DVDs

Asked by eneas on 2008-10-02

I just intalled Linux now, Umbutu, and tried to play a DVD. But it doesnt, and I tried many applications like VLC, Kaffeine, Noatun and others.

But when I tried to play a DVD with area code 0, which means no area code at all, than it plays fine. But most of my DVDS are area code 2 and 4.

what should be done?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu kdemultimedia Edit question
Assignee:
No assignee Edit question
Last query:
2008-10-02
Last reply:
2008-10-02
Jim Hutchinson (jphutch) said : #1

Due to licensing restrictions Ubuntu cannot include the software that decrypts commercial DVDs. You have to install that yourself. See https://help.ubuntu.com/community/Medibuntu and install libdvdcss.

Play mp3 and dvd under Ubuntu

First please install https://help.ubuntu.com/community/RestrictedFormats

You need to have extra repositories enabled...

Please first enable the multiverse repository:

Open System → Administration → Software sources → [ Tab Ubuntu software ]
enable "Software restrictecd by copyright or legal issue ( multiverse )"
Close and confirm the repository reload.

Type the following command in a terminal (applications → accessories → terminal)

sudo aptitude install vlc

To get better dvd playback first you need to add the medibuntu http://www.medibuntu.org/ repository to your /etc/apt/sources.list file:
here howto add https://help.ubuntu.com/community/Medibuntu here the medibuntu available software list http://packages.medibuntu.org/

Then to install:

sudo update
sudo aptitude install libdvdread3 libdvdnav4 libdvdcss2

give your user password when requested, you don't see nothing when you type it, then press enter.

Hope this helps

Can you help with this problem?

Provide an answer of your own, or ask eneas for more information if necessary.

To post a message you must log in.