speaker/headphone switch does not work

Asked by trisodium on 2008-04-16

Hi. I am currently using Kubuntu 7.10. I only started using Linux a few months ago, so please keep that under consideration if offering a solution (or my failed attempts at solving this issue).

When I plug in my headphones to the jack of my Toshiba Satellite laptop, the audio on the computer speakers does not turn off.
It seems that many people with different laptops have had this issue. Other forums suggest checking a box called "Headphone Jack Sense" in KMix or Alsamixer. Neither of these options seem to exist in the versions I have installed even though they appear to be up to date versions. Some people had success by adding "options snd-hda-intel model=laptop" to the end of /etc/modprobe.d/alsa-base, however this has not produced any change in my issue. I assumed restarting after this edit should be sufficient to produce the intended results. I also tried recompiling ALSA to no avail.

I should add that I am quite certain this is not a hardware failure. The switch between headphone and external speakers worked when we first purchased the laptop and it was running Vista. The behavior changed immediately, when I installed Kubuntu.

I am surprised there are not at least independent volume controls for the two output ports. Having that option would be an acceptable work around to me. I just want to be able to listen to music on the airplane or any other public place. Also I fear this issue may interfere with my attempts to use VoIP when I am out of the country.

Thanks for any help that can be provided.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu kdemultimedia Edit question
Assignee:
No assignee Edit question
Last query:
2008-04-16
Last reply:
2008-04-17
Volans (volans) said : #1

I can confirm this problem on Ubuntu 7.10 on a Asus F3 laptop. I have tried the same solutions you explained without any change.
For me this is a new problem appeared about 2 weeks ago. Previously all worked fine with the same system configuration.
I don't have found in Synaptic history any package update that can be related to this bug.

Obviously I'm also interested in any possible solution or work around.

Can you help with this problem?

Provide an answer of your own, or ask trisodium for more information if necessary.

To post a message you must log in.