How to record audio from MIC or LINE under Kubuntu?

Asked by Uqbar on 2011-01-14

I need to record audio (16bit 44.1 or 48 Khz stereo samples) from MIC or LINE inputs.
I remember about a KDE tool called KRec which seems to have been discontinued under KDEv4.
What should I use instead?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu kdemultimedia Edit question
Assignee:
No assignee Edit question
Solved by:
Eliah Kagan
Solved:
2011-02-12
Last query:
2011-02-12
Last reply:
2011-01-15
arochester (arochester) said : #1

Audacity?

Uqbar (uqbar) said : #2

Have found to simple way to do configure it to do it.
But is KRec gone?

The short answer to your question is: yes, KRec is no longer available in KDE4.

The very much longer answer is that KRec depends on the aRts framework (see http://www.arts-project.org/ and http://en.wikipedia.org/wiki/ARts and bug 320915), which is present in KDE up to major version 3, but not present in KDE4. So KRec died with aRts (see http://lists.kde.org/?l=kde-multimedia&m=111765303930494&w=2).

It might be possible for you to run KRec on a current Ubuntu system. But it would likely be more effort than it's worth. A lot of old software that used to be packaged for Ubuntu but no longer is, like KRec, can be installed by downloading the old .deb packages from Launchpad and installing them. The latest package version of KRec for Ubuntu is krec package version 4:3.5.10-0ubuntu1~hardy1, which was provided by hardy-backports and hardy-updates (see http://packages.ubuntu.com/hardy-updates/krec).

You actually *can* install that version of krec on a Kubuntu 10.10 Maverick system. Getting it to work is another matter. KRec was part of kdemultimedia back in the Hardy days. kdemultimedia still exists and is part of KDE4, but it doesn't contain KRec. Fortunately, KRec is provided by its own package, which can be downloaded by going to https://launchpad.net/ubuntu/+source/kdemultimedia and expanding 4:3.5.10-0ubuntu1~hardy1 under The Hardy Heron, and then finding the krec .deb file for your architecture.

For i386, that would be:
https://launchpad.net/ubuntu/+archive/primary/+files/krec_3.5.10-0ubuntu1~hardy1_i386.deb

And for amd64, that would be:
https://launchpad.net/ubuntu/+archive/primary/+files/krec_3.5.10-0ubuntu1~hardy1_amd64.deb

That package has various dependencies, some of which can be satisfied automatically by the package manager (with current packages in Maverick), and some of which cannot. To install that krec package, you will first need to manually install libartsc0, libarts1c2a, and artsbuilder (in that order).

artsbuilder, like krec itself, is part of Hardy's kdemultimedia package. To get it, you can go to https://launchpad.net/ubuntu/+source/kdemultimedia and expand 4:3.5.10-0ubuntu1~hardy1 under The Hardy Heron (if you don't still have that up, from when you downloaded krec), and then find the artsbuilder .deb file for your architecture.

For i386, that would be:
https://launchpad.net/ubuntu/+archive/primary/+files/artsbuilder_3.5.10-0ubuntu1~hardy1_i386.deb

And for amd64, that would be:
https://launchpad.net/ubuntu/+archive/primary/+files/artsbuilder_3.5.10-0ubuntu1~hardy1_amd64.deb

To get libartsc0 and libarts1c2a, go to https://launchpad.net/ubuntu/+source/arts, expand 1.5.10-0ubuntu1~hardy1 under The Hardy Heron, and then find the libartsc0 and libarts1c2a .deb files for your architecture.

For i386, those would be:
https://launchpad.net/ubuntu/+archive/primary/+files/libartsc0_1.5.10-0ubuntu1~hardy1_i386.deb
https://launchpad.net/ubuntu/+archive/primary/+files/libarts1c2a_1.5.10-0ubuntu1~hardy1_i386.deb

For amd64, those would be:
https://launchpad.net/ubuntu/+archive/primary/+files/libartsc0_1.5.10-0ubuntu1~hardy1_amd64.deb
https://launchpad.net/ubuntu/+archive/primary/+files/libarts1c2a_1.5.10-0ubuntu1~hardy1_amd64.deb

Once you've downloaded and installed those three dependencies and then krec (in the order: libartsc0, libarts1c2a, artsbuilder, krec), you can run krec. But it will immediately exit with an error:

krec: error while loading shared libraries: libartskde.so.1: cannot open shared object file: No such file or directory

That's when I stopped testing this on Kubuntu 10.10 Maverick. (Yes, all the previous instructions have been tested on a fully-updated Maverick system.)

The problem is that the library file libartskde.so.1 was part of the kdelibs package back in KDE3, but has been removed from the kdelibs4c2a package in KDE4. Old versions of the kdelibs4c2a package are available on Launchpad, but you don't want to try to revert to that, because it would cause vast breakage in your KDE4-based Kubuntu system. Instead, you could try picking the libartskde.so.1 file out of Hardy's kdelibs4c2a .deb file from Launchpad and plopping it in the /usr/lib directory, and seeing what happens. Or, as a somewhat worse alternative, you could get a copy of it from another system running KDE3. (I probably don't need to say that, if you use one of these methods, this file will not be updated when you update your system, as it won't have a package associated with it!) Or, you could investigate if aRts support is perhaps still present in the source for kdelibs4c2a, and if it is, you could reinstall kdelibs4c2a from the source package, and build the source with aRts support enabled, to get a libartskde.so.1 file. I suspect that if it were that easy then aRts support would have been moved into optional packages rather than eliminated from KDE4, but you never know. Searching the web for other attempts to achieve this might be fruitful as well.

Please note that if you do manage to get a working /usr/lib/libartskde.so.1, that still doesn't mean you won't have other problems that will prevent KRec from actually working. I just don't know what those other problems would be, since I stopped at the error about libartskde.so.1.

Note also that, without hardy, hardy-updates, and hardy-backports in your /etc/apt/sources.list file (and I think you really don't want them there), you wouldn't receive automatic updates to these manually-installed Hardy packages, though you could go to Launchpad and manually download and install updates as they are released. Note also that support for Ubuntu 8.04 LTS Hardy Heron desktop systems ends this April. It occurs to me that gNewSense 2.3 (which is that distro's current version) is based on Hardy; perhaps it will continue to have support and security updates for these packages after 4/2011. Like all Ubuntu releases, Hardy is based on Debian; perhaps Debian will continue to provide supported packages past that date as well. You could easily check into these matters.

If you decide to look into and/or try any of these things, then more power to you! If they succeed at enabling you to run KRec, or if they don't, I'd be pleased to hear about it; you could add a comment to this question. However, please do not take anything that I am saying in this post as actual encouragement for you to attempt to get KRec working. It's probably not worth your time.

Uqbar (uqbar) said : #4

Thanks Eliah Kagan, that solved my question.