New windows don't get focus

Asked by Gregor Müllegger on 2008-10-31

Binary package hint: kdebase-workspace

Yesterday i installed the new kubuntu intrepid release. But i have a problem with the focus' of windows.

If i open the K-Menu in the bottom left corner and open e.g. dolphin, the currently active window will remain the same and dolphin is hidden behind that active window. But i want that newly created windows get the focus.

I looked through all config options in KDE but didn't found anything that could solve the problem.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu kdebase-workspace Edit question
Assignee:
No assignee Edit question
Solved by:
Harald Sitter
Solved:
Last query:
Last reply:

This question was originally filed as bug #291434.

Harald Sitter (apachelogger) said : #1

This is actually more of a support request than a bug report. Converting to question.

Best Harald Sitter (apachelogger) said : #2

You could try right clicking on window -> configure window behavior -> advanced -> play with the focus stealing prevention level.

Thank you for your answer. I think it worked.
Maybe the developers should rethink the default option "high" ...

This is not what the average user coming from windows/gnome/kde3 will expect. And it's not the option that makes most sense for a smooth workflow.