KDE startup and shutdown problems

Asked by Clive Nicholas on 2013-01-23

Kubuntu 12.04, KDE 4.8.5

Hello!

I'm having one or two difficulties with the KDE startup and shutdown procedure at the moment.

My issue began on Monday. I logged into KDE as normal, but instead of getting the startup screen, I instead got a black screen with two or three lines, the last of which was:

Stopping System V runlevel compatibility

and I was then returned to the login screen. I logged in again and it happened again. And again. And so on.

After digging around the Linux messaging forums, I eventually found the solution that enabled me to login successfully:

sudo service kdm stop
startx -- :0 (or startx)

All my settings, programs and internet browser tabs have been preserved. However, I have discovered that I have no authorization to access any removable drives and there is no audio on any clips I play, on- or offline.

When I clicked to leave the session, I discovered that the default leave options do not display the icons for 'Turn off computer' or for 'Restart computer'. I was dismayed by that, as it suggests I've logged into an additional session with a session still running, which appears to be confirmed by

clive@clivubu:~$ ck-list-sessions
Session2:
        unix-user = '1000'
        realname = 'Clive Nicholas'
        seat = 'Seat1'
        session-type = ''
        active = FALSE
        x11-display = ''
        x11-display-device = ''
        display-device = '/dev/tty1'
        remote-host-name = ''
        is-local = TRUE
        on-since = '2013-01-23T17:00:23.096660Z'
        login-session-id = ''
        idle-since-hint = '2013-01-23T17:01:48.542131Z'
Session3:
        unix-user = '1000'
        realname = 'Clive Nicholas'
        seat = 'Seat2'
        session-type = ''
        active = FALSE
        x11-display = ':0'
        x11-display-device = '/dev/tty8'
        display-device = '/dev/tty1'
        remote-host-name = ''
        is-local = FALSE
        on-since = '2013-01-23T17:01:21.410602Z'
        login-session-id = ''

Checking the Session Management settings show they are at their default settings. Selecting 'Start with an empty session' and restarting changes nothing.

Selecting 'Log out' on leaving, then typing logout at the terminal prompt and then switching my machine off and on to login again produces the same login issues as in the beginning, only this time it produces more statements at the black screen, which I have been able to capture:

Stopping log initial device creation
Starting enable remaining boot-time encrypted block devices
Starting configure network device security
Starting configure virtual network devices
Stopping configure virtual network devices
Stopping enable remaining boot-time encrypted block devices
Stopping System V runlevel compatibility

after which I am then returned to the login screen.

I have never encountered this before and would obviously like to resolve whatever problem is causing this issue. Does anybody have any idea as to what is going on?

Thanks in anticipation of your help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu kde-workspace Edit question
Assignee:
No assignee Edit question
Solved by:
Clive Nicholas
Solved:
2013-02-02
Last query:
2013-02-02
Last reply:
2013-01-24
Clive Nicholas (clivenicholas) said : #1

Kubuntu 12.10, not 12.04!

If you make a fresh user and log in, do you get no issues there?

Clive Nicholas (clivenicholas) said : #3

Andrew,

I tried that, but making a fresh user and login produced a scratch system with none of my files, programs and settings carried over (I even ticked all the Groups boxes in User Management). So I still have the same problem.

Yours,
Clive

I don't care about the files, this isn't the issue. Does the system shutdown ok?

Clive Nicholas (clivenicholas) said : #5

Sorry Andrew, but I bloody well DO care about that issue, even if you don't!

Yes, the system does shut down properly on a new login, but what I want is a resolution of the problem that I stated quite clearly: that means logging onto my Linux system with everything intact without a black screen spitting out errors and simply returning me back to the same login screen.

What you propose, I'm sorry to say, does not resolve this.

It wasn't to fix it, it was to see if your user settings or permissions are causing the problem

The new user is ok, as you say, so we now know that the issue is not the OS itself. It's called "exploring the issue" or "problem isolation". You need to test certain things to see what happens to then make a move.

Your user files and so forth will not have been "pulled through" as the new user has its own user files just like in Windows. Imagine if every new user receivd a copy of the first user's files. Not only would it be grossly unsecure but the potential to fill the storage would be significantly easier. How did you come about this notion?

Clive Nicholas (clivenicholas) said : #7

This is all very interesting, but from what you're saying, I may as well reinstall Kubuntu to achieve the same outcome that you're describing. But still no explanation as to why I apparently have two sessions running, and how I can end one of them to return my Linux system to the state it was in prior to Monday.

Clive Nicholas (clivenicholas) said : #8

Sorry for the delay, but I eventually solved the problem by reinstalling. It also cleared a lot a 'dead' files from my system as well, so it was the best solution. Thanks for your help.