No Plugin found but libdvdcss2 iS installed

Asked by rodgerpb


I am really trying to get my machine to play DVD's.

On Kaffeine I get a dialog

The source can't be read.
Maybe you don't have enough rights for this, or source doesn't contain data (e.g: no disc in drive). (/dev/dvd)

Then I get the following diagnostic;

No plugin found to handle this resource (dvd://)

The details screen gives

09:07:52 PM: xine: cannot find input plugin for MRL [dvd://]
09:07:52 PM: xine: input plugin cannot open MRL [dvd://]
09:07:51 PM: xine: found input plugin : DVD Navigator

i do have libdvdcss2 and W32codecs installed (tried both the latest version and the version available from Automatix [Yes I do live OUTSIDE the US]), but nothing seems to work
I have tried Regionset and my DVD is set to R2 (which is most of my DVDs).

Any advice please - as I am about to give up

Many thanks


Question information

English Edit question
Ubuntu kaffeine Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Wrwrwr (wrwrwr) said :

Try using a different player, e.g. totem with totem-gstreamer, or mplayer, you can install these with your package manager (for mplayer you need to enable universe repository).

There are some known problems with Automatix, one of which is this imprecise message, legality of using these w32codecs doesn't really have to do much with being or not being in the US.

Revision history for this message
Wrwrwr (wrwrwr) said :

Sorry, you need to enable multiverse not universe for mplayer.

Revision history for this message
rodgerpb (rodger-barnett) said :

Thanks...I have tried MPlayer, but DVD's still don't play on that. I don't get any kind of diagnostics with MPlayer, it just does not work. I am sure that I added the universe repository to my sources.list file.

I have not tried totem-gstreamer, but I have had some problems with the gstreamer-bad plugins (multiverse variants). I end up with Add/Remove telling me that I have conflicting software, and Synaptic telling me that I have broken packages. The only way round that was 'completely remove' gstreamer-bad plugins (multiverse variants).

Perhaps you know why one player should work but others do not?



Revision history for this message
Wrwrwr (wrwrwr) said :

There are tons of formats, codecs etc., many with different legal issues, so the current state of multimedia support in linux is such, that there is no one ideal player or backend. That's why gstreamer instead of xine is worth trying.

Enabling universe is needed just for installing mplayer, not for running it.

Broken packages etc. may again be caused by automatix, it is known for many quirks, but i've never tried it so can't really tell. You can try fixing dependencies from synaptic (in edit menu), or from a terminal: "sudo apt-get --fix-broken install".

Some info about playing dvds with mplayer:

Revision history for this message
rodgerpb (rodger-barnett) said :

Hi..I added totem-gstreamer from Synaptic, and also 'all gstreamer' packages from Synaptic, which appears to include a dvd plugin in the list.

Still cannot play DVD's

The error box from totem is
Totem cannot play this type of media (DVD) because you do not have the appropriate plugins to to handle it

The movie menu in Totem recognises the film that I have put in the DVD drive (in this case Fantasia 2000).

I have to say this is probably the most frustrating thing that I have found since a virus destroyed my build of WIndows 98.

If there are any obvious plugins that I should check for the please let me know.

Many thanks


Revision history for this message
Wrwrwr (wrwrwr) said :

Try installing ubuntu-restricted-extras, kubuntu-restricted-extras packages.

Maybe you know in what format the movie on the dvd is?

Here's a standard how-to on those things including some more troubleshooting:, maybe you'll find something there.

You can try running mplayer in debug mode: mplayer -msglevel 9, or 7 for less output, maybe that would give us some more insight.

Revision history for this message
shinyblue (shinyblue) said :

I have the same kaffeine problem but it appears to be caused by a missing symlink

do this:
$ sudo ln -s /dev/dvd1 /dev/dvd

And it plays as expected.

I've only had this problem since upgrading to Gutsy (which seemed to break lots!)

Hope this helps.

Can you help with this problem?

Provide an answer of your own, or ask rodgerpb for more information if necessary.

To post a message you must log in.