K3B in Karmic: No MP3 ripping or burning.

Asked by Jan Glud on 2009-11-14

I have installed the extra-codecs from Synaptic, well several times, but the option to rip to MP3 does not appear. And I have tried to burn some MP3 files. That was denied. It all worked welli Jaunty.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu k3b Edit question
Assignee:
No assignee Edit question
Solved by:
Jan Glud
Solved:
2009-11-15
Last query:
2009-11-15
Last reply:
2009-11-14

To burn mp3s to an audio CD, you need the proper codecs to do the conversion, and those codecs are not installed by default. You need to install the libk3b3-extracodecs package as follows:

sudo apt-get install libk3b3-extracodecs

You should also read these:

https://help.ubuntu.com/community/Repositories/Ubuntu
https://help.ubuntu.com/community/Medibuntu

Then if previous answer doesn't solve...

Please read → ( the unixchaos reply on 2009-11-01: ) here: https://answers.launchpad.net/ubuntu/+source/k3b/+question/87259

Hope this helps

Jan Glud (janhan) said : #3

Hey Marco. Thanks for the fast replies. - I tried to install libk3b3-extracodecs but was told it did not exist and that it was replaced by libk3b6, which I already have. I then added libmad0 and libmp3lame0. - But that does not seem to change anything.

Jan Glud (janhan) said : #4

In usr/lib/KDE4 you find 3 kinds of kcm_k3b: an -ex an -ogg and a -se. In another distro I stumbled upon (well rpm-based) there is also a kcm_k3blame in this folder.Would it be thinkable that this fellow just didn't make it into the Kubuntu-deb?
Anyway my K3B now seems to be acepting Mp3 burning, and that is the main thing for me. - The ripping to Mp3 still doesn't work, but I'll just install Asunder or
someting like that. - Thanks for the help!

Rob Spangler (rob-spangler) said : #5

Here's what solved this problem for me: installed the LAME package.

I had all the k3b-extracodecs, etc... installed and re-installed. When I read Jan Glud's comment regarding Asunder I decided to give it a go. When I ran it right after install, it said something to the line of "All MP3 operations disabled because Lame is not installed" (I don't recall the exact verbiage...) Anyway, checked Synaptic and sure enough, I had LIBMP3LAME0 installed, but the actual LAME package itself was not.

Hope this helps!

Rob Spangler

Jan Glud (janhan) said : #6

Summing up: I added libmad0 and libmp3lame0: Now K3B can burn MP3 - after restarting, mind you! Then I added lame: Now K3B can rip MP3. Works on my machine. - Thanks Marco and Rob!

Danny Johnson (bunjee) said : #7

Does K3b burn MP3's? I did an install and can't see any indication where to burn MP3's in K2b. I have Intrepid 8.10.
Please advise.