mp3 encoding error in anarok

Asked by Davinciman on 2009-10-28

I can rip music in ogg-vorbis but not mp3

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu k3b Edit question
Assignee:
No assignee Edit question
Last query:
2009-10-31
Last reply:
2009-11-25
unixchaos (jza873) said : #1

install lame

sudo apt-get install lame

Davinciman (uknowme1967) said : #2

I installed lame but still no dice.
automatically ejects disk while trying to encode 1st track with K3B
When I click device both mount and unmount are greyed out
Thanks ,I will keep trying

PS it' a Philips SPD3100l Ram/DvdRw usb drive . It has always worked
before (Hardy Heron live) ripping music and burning Dvds

On 10/28/09, unixchaos <email address hidden> wrote:
> Your question #87259 on k3b in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/k3b/+question/87259
>
> Status: Open => Answered
>
> unixchaos proposed the following answer:
> install lame
>
> sudo apt-get install lame
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+source/k3b/+question/87259/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/k3b/+question/87259
>
> You received this question notification because you are a direct
> subscriber of the question.
>

Davinciman (uknowme1967) said : #3

Here is the debug:

System
-----------------------
K3b Version: 1.0.5

KDE Version: 3.5.10
QT Version: 3.3.8b
Kernel: 2.6.28-11-generic
Devices
-----------------------
HL-DT-ST DVD-ROM GDR8164B 0B10 (/dev/sr0, ) [CD-ROM, DVD-ROM] [DVD-ROM, CD-ROM] [None]

PHILIPS SPD3100L M5S2 (/dev/sr1, ) [CD-R, CD-RW, CD-ROM, DVD-ROM, DVD-R, DVD-RW, DVD-R DL, DVD+R, DVD+RW, DVD+R DL] [DVD-ROM, DVD-R Sequential, DVD-R Dual Layer Sequential, DVD-R Dual Layer Jump, DVD-RAM, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW] [SAO, TAO, RAW, SAO/R96P, SAO/R96R, RAW/R16, RAW/R96P, RAW/R96R, Restricted Overwrite, Layer Jump]

Is this a permission problem?

Thanks so far Unixchaos

unixchaos (jza873) said : #4

Did you install lame. lame is a mp3 encoder

no... i dont beleive so. but you know there is a very easy way to rip files better and faster right.

open konqueror

make sure the cd is inserted

audiocd:/ <--type that in the url filed and press enter

copy the MP3 folder to where ever you want.

this is also a test. if the mp3 folder has content in it then lame is functioning correctly. if you dont have a folder lemme know what you have.

Davinciman (uknowme1967) said : #5

Yes I installed lame and I can see the files on audocd in the main drive but not on ext. drive. It used to read them from there as well, before lame. I just tried your mp3 ripping trick, which I like a lot, but its all static.
I'll keep trying

Your help is appreciated

cheers

unixchaos (jza873) said : #6

do you have gstreamer installed

if you dont or dont know

open add/remove programs and type mp3 it should be the first 3 ones

or you can do them all by hand here is what i got

gstreamer0.10-alsa
gstreamer0.10-ffmpeg
gstreamer0.10-nice
gstreamer0.10-pitfdll
gstreamer0.10-plugins-bad
gstreamer0.10-plugins-bad-multiverse
gstreamer0.10-plugins-base
gstreamer0.10-plugins-base-apps
gstreamer0.10-plugins-good
gstreamer0.10-plugins-ugly
gstreamer0.10-plugins-ugly-multiverse
gstreamer0.10-pulseaudio
gstreamer0.10-tools
gstreamer0.10-x

install that and see if it helps

btw you said its all staticy. can you try playing another mp3 that is on your system and let me know if its all staticy cause if it is iy may be an audio driver problem

Davinciman (uknowme1967) said : #7

It's a new install no media
I have played/ripped music before since install, ogg-vorbis worked but files were huge
Nothing since lame though and now philips drive I was using won't read any more
I looked for gstreamer but didn't see it
I will sudo apt-get for it now

Thanks

Davinciman (uknowme1967) said : #8

Ok
I found it, gstreamer0.10-fluendo-mp3, installed it...no go
when I open k3b start ripping...command failed lame -h -tt Brown Sugar.... something like that
It's starting to make me crazy
I didn't see near the list you had though

unixchaos (jza873) said : #9

try this sudo apt-get install libmp3lame0 libk3b2-mp3

ha try that lemme know if it works

unixchaos (jza873) said : #10

forget about the previous comment ignor it

libk3b2-mp3 dosnt exist any more so x that one

i forgot install these too

sudo apt-get install libk3b6 libk3b6-extracodecs libmad0 libmp3lame0

install them then in k3b go to

settings-->configure k3b-->plugins and make sure all of them are checked

zohar995 (zohar995) said : #11

Thanks unixchaos it seems to work for karmic

unixchaos (jza873) said : #12

hay after the question is answered you should mark it as solved so no one keeps looking at a closed ticket

Can you help with this problem?

Provide an answer of your own, or ask Davinciman for more information if necessary.

To post a message you must log in.