Not enough space in temp. directory?

Asked by ricbritain on 2009-04-06

New to Linux and new to K3b. When i try the 'copy DVD' command from the TOOLS tab I get the message 'not enough space in temporary directory'. I have checked in the 'image' tab and it says only 141mb space in the temp directory, but that I need 4.7Gig. I've tried changing it but it remains the same size. What should I do??

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu k3b Edit question
Assignee:
No assignee Edit question
Solved by:
ricbritain
Solved:
2009-04-09
Last query:
2009-04-09
Last reply:
2009-04-06
Bhavani Shankar (bhavi) said : #1

To clean up your hard drive and free up some space in a Applications--Accessories-->Terminal type:

sudo apt-get clean

and

sudo apt-get autoremove

ricbritain (richardbrotton) said : #2

I entered the first line and it didn't do anything. After entering the second line I got the following:

E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
richard@richard-laptop:~$

Isn't it a lot to clean up, from 141mb to 4.4Gig? I'm on an ASUS eeePC but there isn't a lot else on it.

Bhavani Shankar (bhavi) said : #3

Aha To unlock it, close the application that's using the package database.

Refer this link

http://www.ubuntugeek.com/how-to-fix-lock-varlibdpkglock-open-11-resource-temporarily-unavailable-error.html

ricbritain (richardbrotton) said : #4

Ok. I.ve done it! I basically had to search through the drives to find the one with free memory. then I had to unlock it to allow k3b to use it. Then set it as the temp. directory. Brilliant! I will give the package a full test tomorrow, as its midnight here and I'm in bed. Thanks for the help.