Ubuntu

burn DVDs that can be viewed with dvd player

Asked by Patrick M on 2009-01-26

I am running intrepid (Ubuntu 8.10) I would like an app that will allow me to burn avi and other formats (mp4, mv, wmv etc. onto DVD for playback on dvd players. TOVID wouldn't download, got 404 page not found error when I try

Any other ideas? I have deb installer, is there a way to make a tarball work on my pc? I am still a bit of a newbie, but am comfortable with the CLI

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu k3b Edit question
Assignee:
No assignee Edit question
Solved by:
Kayvee
Solved:
2009-02-03
Last query:
2009-02-03
Last reply:
2009-02-02
Bhavani Shankar (bhavi) said : #1

I use k9copy

https://help.ubuntu.com/community/K9Copy

and it works fine with me

Additionally

See this list of softwares.

https://help.ubuntu.com/community/DVDAuthoring

and this link

http://linuxowns.wordpress.com/2008/10/07/how-to-rip-a-dvd-in-ubuntu-to-avi-the-easy-way/

then to compile and install a tarball please see:

https://help.ubuntu.com/community/CompilingEasyHowTo

regards

Tom (tom6) said : #2

I use Brassero from the "Applications" menu on the top task-bar, look in "Sounds & Video", it takes a bit of getting used to as it automatically detects a lot of things that most burners need to be told. Also many of it crucial options (such a multisession) only appear after hitting the Burn button.

Generally it's good to lookup software in the 'Add/Remove Programs' searchable applications installer. Find that at the end of the Applications menu. It takes a few moments to hunt out the available software in the repositories. Items that are ticked are already installed. To install something new just tick it and click apply. I prefer the Synaptic Package Manager that's in System - Administration - Synaptic is near the end of the list but its just personal taste really.

Good luck and welcome to the weird and wonderful land of linux
Regards from
Tom :)

Tom (tom6) said : #3

The search feature in the package managers defaults to looking in the descriptions, not just the names.

Linux is wierd in not having a "Start" button to turn the machine off and also its version of "Add/Remove Programs" can actually add programs too.

I cant help feeling that it just creates trouble by naming things according to what they really do. ;)

Patrick M (prmillius) said : #4

I have brasero, but it only gives me the option burning data DVD.
I will try K9
Note: I am not trying to copy a DVD, I want to Author from files stored on other media. I understand this requires converting to mpeg2 (ntsc) dvd codec

Does K9 do this?

Also can a file be converted and burned using LiVES? if so, how?

Thanks!

Tom (tom6) said : #5

Oh, weird. When i open Braserro or go up to "Project" menu at the top and choose "New" it gives me the options of Audio, Video, Data and about 3 other choices. Maybe i do have some funny codecs but i haven't got a clue which i've got. Sorry i can't help here

Good luck
Regards from
Tom

Tom (tom6) said : #6

K3b is supposed to be good but thats KDE based so it may drag in a lot of dependancies. I've not heard of K9, except the dog of course ;)

Patrick M (prmillius) said : #7

I think I have tried every app. now, still no luck. I can burn data DVDs but none that will play in a DVD player. k3b had error downloading, but will burn data dvds.

Patrick M (prmillius) said : #8

Here's the terminal data when I try to get the codecs:
millius@millius:~$ sudo wget http://www.medibuntu.org/sources.list.d/intrepid.list -O /etc/apt/sources.list.d/medibuntu.list && wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add - && sudo apt-get update && sudo apt-get install -y ubuntu-restricted-extras non-free-codecs w32codecs totem-mozilla libdvdcss2
[sudo] password for millius:
--2009-02-02 09:38:56-- http://www.medibuntu.org/sources.list.d/intrepid.list
Resolving www.medibuntu.org... 87.98.242.110
Connecting to www.medibuntu.org|87.98.242.110|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 230 [text/plain]
Saving to: `/etc/apt/sources.list.d/medibuntu.list'

100%[======================================>] 230 --.-K/s in 0s

2009-02-02 09:38:57 (12.8 MB/s) - `/etc/apt/sources.list.d/medibuntu.list' saved [230/230]

OK
Hit http://security.ubuntu.com intrepid-security Release.gpg
Ign http://security.ubuntu.com intrepid-security/main Translation-en_US
Hit http://us.archive.ubuntu.com intrepid Release.gpg
Ign http://us.archive.ubuntu.com intrepid/main Translation-en_US
Get:1 http://packages.medibuntu.org hardy Release.gpg [197B]
Ign http://packages.medibuntu.org hardy/free Translation-en_US
Ign http://security.ubuntu.com intrepid-security/restricted Translation-en_US
Ign http://security.ubuntu.com intrepid-security/universe Translation-en_US
Ign http://security.ubuntu.com intrepid-security/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com intrepid/restricted Translation-en_US
Hit http://security.ubuntu.com intrepid-security Release
Ign http://us.archive.ubuntu.com intrepid/universe Translation-en_US
Ign http://us.archive.ubuntu.com intrepid/multiverse Translation-en_US
Hit http://us.archive.ubuntu.com intrepid-updates Release.gpg
Ign http://us.archive.ubuntu.com intrepid-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com intrepid-updates/restricted Translation-en_US
Ign http://us.archive.ubuntu.com intrepid-updates/universe Translation-en_US
Ign http://us.archive.ubuntu.com intrepid-updates/multiverse Translation-en_US
Hit http://us.archive.ubuntu.com intrepid Release
Ign http://packages.medibuntu.org hardy/non-free Translation-en_US
Get:2 http://packages.medibuntu.org intrepid Release.gpg [197B]
Ign http://packages.medibuntu.org intrepid/free Translation-en_US
Ign http://packages.medibuntu.org intrepid/non-free Translation-en_US
Get:3 http://packages.medibuntu.org hardy Release [11.7kB]
Hit http://us.archive.ubuntu.com intrepid-updates Release
Hit http://security.ubuntu.com intrepid-security/main Packages
Get:4 http://packages.medibuntu.org intrepid Release [11.7kB]
Hit http://us.archive.ubuntu.com intrepid/main Packages
Hit http://us.archive.ubuntu.com intrepid/restricted Packages
Hit http://us.archive.ubuntu.com intrepid/main Sources
Hit http://us.archive.ubuntu.com intrepid/restricted Sources
Hit http://us.archive.ubuntu.com intrepid/universe Packages
Hit http://security.ubuntu.com intrepid-security/restricted Packages
Hit http://security.ubuntu.com intrepid-security/main Sources
Hit http://security.ubuntu.com intrepid-security/restricted Sources
Hit http://security.ubuntu.com intrepid-security/universe Packages
Hit http://us.archive.ubuntu.com intrepid/universe Sources
Hit http://us.archive.ubuntu.com intrepid/multiverse Packages
Hit http://us.archive.ubuntu.com intrepid/multiverse Sources
Hit http://us.archive.ubuntu.com intrepid-updates/main Packages
Hit http://us.archive.ubuntu.com intrepid-updates/restricted Packages
Hit http://us.archive.ubuntu.com intrepid-updates/main Sources
Hit http://us.archive.ubuntu.com intrepid-updates/restricted Sources
Hit http://us.archive.ubuntu.com intrepid-updates/universe Packages
Hit http://security.ubuntu.com intrepid-security/universe Sources
Hit http://security.ubuntu.com intrepid-security/multiverse Packages
Hit http://security.ubuntu.com intrepid-security/multiverse Sources
Hit http://us.archive.ubuntu.com intrepid-updates/universe Sources
Hit http://us.archive.ubuntu.com intrepid-updates/multiverse Packages
Hit http://us.archive.ubuntu.com intrepid-updates/multiverse Sources
Hit http://packages.medibuntu.org hardy/free Packages
Hit http://packages.medibuntu.org hardy/non-free Packages
Get:5 http://packages.medibuntu.org intrepid/free Packages [3518B]
Get:6 http://packages.medibuntu.org intrepid/non-free Packages [12.6kB]
Fetched 28.2kB in 3s (8770B/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
ubuntu-restricted-extras is already the newest version.
w32codecs is already the newest version.
totem-mozilla is already the newest version.
totem-mozilla set to manually installed.
libdvdcss2 is already the newest version.
The following packages were automatically installed and are no longer required:
  libconvert-binhex-perl libtext-bidi-perl libsoap-lite-perl automake1.4
  liboro-java glade-2 libatk1.0-dev python-kiwi libemail-find-perl
  libxml-libxml-common-perl linux-headers-2.6.27-7 libcrypt-ssleay-perl
  libxml-namespacesupport-perl libclass-methodmaker-perl libxml-perl
  x11proto-xinerama-dev glade-common libhtml-fromtext-perl
  epiphany-browser-data libregexp-common-perl linux-headers-2.6.27-7-generic
  m4 autoconf libexporter-lite-perl libxml-sax-expat-perl python-id3
  libarchive-zip-perl libossp-uuid-perl libmime-tools-perl libxml-libxslt-perl
  xmltv-util libossp-uuid15 x11proto-composite-dev libnet-domain-tld-perl
  libxml-dom-perl libxcursor-dev liblog-tracemessages-perl x11proto-randr-dev
  x11proto-damage-dev libio-stringy-perl libhtml-tableextract-perl
  autotools-dev libxml-libxml-perl libgtk2.0-dev libxml-sax-perl
  libnet-ip-perl glade libxdamage-dev libnet-dns-perl x11proto-fixes-dev
  libdate-manip-perl libhttp-cache-transparent-perl libwww-mechanize-perl
  libfile-slurp-perl liblingua-preferred-perl libxcomposite-dev automake
  libfcgi-perl libunicode-string-perl libxml-writer-perl libxrandr-dev
  libemail-address-perl gazpacho libxml-regexp-perl libdigest-hmac-perl
  libemail-valid-perl libxfixes-dev libxinerama-dev libxmltv-perl
  libterm-progressbar-perl dvb-utils libdigest-sha1-perl
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  non-free-codecs
0 upgraded, 1 newly installed, 0 to remove and 4 not upgraded.
1 not fully installed or removed.
Need to get 2220B of archives.
After this operation, 32.8kB of additional disk space will be used.
Get:1 http://packages.medibuntu.org intrepid/non-free non-free-codecs 3 [2220B]
Fetched 2220B in 0s (4975B/s)
Selecting previously deselected package non-free-codecs.
(Reading database ... 189644 files and directories currently installed.)
Unpacking non-free-codecs (from .../non-free-codecs_3_i386.deb) ...
Setting up msttcorefonts (2.5) ...

These fonts were provided by Microsoft "in the interest of cross-
platform compatibility". This is no longer the case, but they are
still available from third parties.

You are free to download these fonts and use them for your own use,
but you may not redistribute them in modified form, including changes
to the file name or packaging format.

Error parsing proxy URL http://:8080/: Invalid host name.
Error parsing proxy URL http://:8080/: Invalid host name.
Error parsing proxy URL http://:8080/: Invalid host name.
Error parsing proxy URL http://:8080/: Invalid host name.
Error parsing proxy URL http://:8080/: Invalid host name.
Error parsing proxy URL http://:8080/: Invalid host name.
Error parsing proxy URL http://:8080/: Invalid host name.
Error parsing proxy URL http://:8080/: Invalid host name.
Error parsing proxy URL http://:8080/: Invalid host name.
Error parsing proxy URL http://:8080/: Invalid host name.
Error parsing proxy URL http://:8080/: Invalid host name.
Error parsing proxy URL http://:8080/: Invalid host name.
Error parsing proxy URL http://:8080/: Invalid host name.
andale32.exe: No such file or directory

All done, errors in processing 1 file(s)
dpkg: error processing msttcorefonts (--configure):
 subprocess post-installation script returned error exit status 1
Setting up non-free-codecs (3) ...
Errors were encountered while processing:
 msttcorefonts
E: Sub-process /usr/bin/dpkg returned an error code (1)
millius@millius:~$

Best Kayvee (vkkodali) said : #9

Check out DeVeDe. It will convert your AVI files into ISO files that you can burn onto a DVD and play in a DVD Player.

Check out this link for a few details about how it works... http://blogcritics.org/archives/2007/02/05/150718.php

Patrick M (prmillius) said : #10

Success!
Here's how I did it:

Create the DVD files with DeeVeeDee. Use the "create disk structure" option. Save to an easily found temporary file. When saved, open the file with k3b. open furhter to find the "video_TS and Audio_TS files. drag and drop into the burn cue. click burn.

Done! easy once figured out.

Thanks all!

Tom (tom6) said : #11

Oooo, credit Kayvee with that answer if you can.

If you can't don't worry - i haven't figured the interface out yet either :)

Regards and congrats to both from
Tom :)

Patrick M (prmillius) said : #12

Thanks Kayvee, that solved my question.

Patrick M (prmillius) said : #13

using the 2 apps together works fine

Thanks again

Tom (tom6) said : #14

Brillinat, nicely done - thanks :)

Randy (rdumas) said : #15

Kayvee you rock the link to DeVeDe solved all my problems. That was the problem is that it was burning the file and not creating an iso image. Thanks, Thanks alot.