How do I run julius?

Asked by Alex Riggle on 2011-01-05

Okay I downloaded julius which is apparently a voice-recognition program. So how do I run it? There's no gnu gui interface that I can find, and the help text is, as usual, only helpful to people who already are familiar with the software. Can I use it to translate speech to text in real time, or just from sound files? How do I start it? HALP!

Thanks,
Alex

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu julius Edit question
Assignee:
No assignee Edit question
Solved by:
Alex Riggle
Solved:
2011-01-17
Last query:
2011-01-17
Last reply:
2011-01-17
marcus aurelius (adbiz) said : #1

not all programs have gui. try pressing ALT-F2 then type "julius" to see if that'll start the program.

Alex Riggle (mousethief) said : #2

Thanks Marcus for answering. Yeah, I know all programs don't have gui; I just meant to indicate that's where I went first to try to run it. I opened a terminal and typed "julius" and nothing happened. Also I tried your alt+F2 method and that didn't work either. At least, nothing visible happened, and there is no "julius" process in the System Monitor.

Thanks again for answering.

Alex Riggle (mousethief) said : #4

I tried to work through translations of the German site, but was unable to install simon. I couldn't make heads or tails of the sourceforge.jp site. I fear that there is something about Linux that my brain is just not equipped to handle.

If you want help installing Simon, please explain exactly what you did and what error messages you have received (or, if there were no error messages, please describe in detail what occurred).

Alex Riggle (mousethief) said : #6

Well that was ages ago so I tried again. On this page:

http://translate.google.de/translate?js=n&prev=_t&hl=en&ie=ISO-8859-1&layout=2&eotf=1&sl=de&tl=en&u=http%3A%2F%2Fwiki.ubuntuusers.de%2FSimon

I saw that I was supposed to run this command:

  deb main http://ppa.launchpad.net/grasch-simon-listens/simon/ubuntu VERSION

I figured I was supposed to replace VERSION with 10.04 so I did.

I received this message:

No command 'deb' found, did you mean:
 Command 'debc' from package 'devscripts' (main)
 Command 'derb' from package 'libicu-dev' (main)
 Command 'dab' from package 'bsdgames' (universe)
 Command 'debi' from package 'devscripts' (main)
deb: command not found

(btw thanks for trying to work through this with me)

Sam_ (and-sam) said : #7

dep http... isn't a command it's the path of repository.

Try this.
There is the ppa incl. howto add it to repository and installing it.
https://launchpad.net/~grasch-simon-listens/+archive/simon
https://help.launchpad.net/Packaging/PPA/InstallingSoftware

Alex Riggle (mousethief) said : #8

Where are my system's software sources, and how do I add something to them?

Sam_ (and-sam) said : #9

> > I figured I was supposed to replace VERSION with 10.04

Regarding 10.04 (Lucid LTS) you may just add the ppa as described on the pages.
Open a terminal and close all package management GUIs, e.g. Synaptic, SoftwareCenter
Type:
sudo add-apt-repository ppa:grasch-simon-listens/simon
sudo apt-get update
sudo apt-get install simon

Side note regarding your other question.
System Administration -> Software Sources
or
System Administration -> Synaptic -> Preferences -> Software Sources
http://www.thecodingstudio.com/opensource/linux/screenshots/scaled/Ubuntu%2010.04/30.gif

> I figured I was supposed to replace VERSION with 10.04 so I did

If you run Lucid LTS 10.04 it would look like this
deb main http://ppa.launchpad.net/grasch-simon-listens/simon/ubuntu lucid

But you don't need this anymore when you added the ppa as described above.

Sam_ (and-sam) said : #10

> > I figured I was supposed to replace VERSION with 10.04 so I did
Correction:
If you run Lucid LTS 10.04 it would look like this
deb http://ppa.launchpad.net/grasch-simon-listens/simon/ubuntu lucid main

Alex Riggle (mousethief) said : #11

Okay Simon started, but I am now lost in the set-up. In particular, setting the volume isn't working. It says to work with my system's volume but when I clicked Preferences>Sound I got "Waiting for sound system to respond" which hung indefinitely. I somehow bypassed this and got into the main program (Simon), and now I can't find anywhere I can go back and re-set the volume.

This may have something to do with my trying earlier today to configure my sound system so that I could have two sources of sound playing at the same time (for instance a YouTube video, and the "new message" noise in a chat window). The help window at Ubuntu told me to uninstall PulseAudio. This didn't allow me to play 2 sound sources at the same time, but also didn't appear to affect the sound playback -- everything that worked before (YouTube, new message noises, etc) still work, just not at the same time. So it was a wash.

Anyway I'm sorry I'm such a dolt -- I'm usually a pretty smart person but a lot of these online instructions assume you know things that beginners don't know, or tell me to do things that simply don't work, and give no instructions whatever about what to do when they don't.

I don't have Simon installed, but perhaps when it says to work with your system's volume it simply means that you should adjust the volume with the volume applet in the GNOME Panel (near the upper-right corner of your screen), rather than within Simon itself. Have you tried that? (This is, presumably, the way you typically adjust the sound volume in your Ubuntu system.)

Alex Riggle (mousethief) said : #13

Well, there is nothing on the GNOME panel about volume, and there's nothing in "Add to Panel" (you get that when you right-click on the panel) that has anything to do with volume.

What I tried to do is work through the System menu, System>Preference>Sound; that's when it froze and I got the 'Waiting for sound system to respond' message.

I think I'll take that message back to the Ubuntu forum.

Thanks for all your help! I may be back.

The volume control is part of the Indicator Applet. If you don't see a little speaker icon in your panel, the the Indicator Applet is the one you want to add when you go to Add to Panel.

Alex Riggle (mousethief) said : #15

The indicator applet adds a battery/power button, and an email button, but no speaker button.

Did you have a speaker button back before you removed PulseAudio?

Have you tried re-adding PulseAudio yet, to see if that renders System > Preferences > Sound usable again?

Sorry, I hadn't read your latest message at https://answers.launchpad.net/ubuntu/+source/alsa-driver/+question/141746. Now that you've reinstalled PulseAudio and have usable sound controls in System > Preferences > Sound, are you able to get Simon working?

Alex Riggle (mousethief) said : #18

Not yet but it's mostly because of confusion at the complexity of setting up a "model" (whatever that means), a vocabulary list, and so on. I've got an email in to the simon person here at launchpad; I'm hoping he'll be able to walk me through it.

As for the speaker button, yes, I used to have one. I've tried removing the indicator applet and re-installing it several times; that doesn't help.

I'm going to close this one and if the lack of a speaker button really bothers me, start another with that as its sole subject.

Thanks again for all your help.

Sam_ (and-sam) said : #19

> setting up a "model" (whatever that means)

Means Speech recognition
http://en.wikipedia.org/wiki/Speech_recognition

According to the Wiki you need to compile HTK toolkit, therefore you need to register to get a password which allows you to download the source code.
After unpacking you need to read the README file which explains how to install HTK.

Before installing HTK you need to install other packages.
libx11-dev
libasound2-dev

plus in case of running 64bit architecture.
libc6-dev-i386

To be able to compile it nees additional packages.
https://help.ubuntu.com/community/CompilingEasyHowTo

HTK uses ALSA, so not sure if it works with pulseaudio.
To get a positive result for speech recognition try to set everything to ALSA in
system preferences -> Multimedia system selector (gstreamer-properties)

https://help.ubuntu.com/community/SoundTroubleshooting

To see the speaker symbol in indicator-applet you need the package indicator-sound.
## When removing something, e.g. pulseaudio, you need to pay attention to what will be removed in additon, e.g. Synaptic and terminal will inform you, (don't know about SoftwareCenter, cause I don't use it).

Check out Synaptic (system administration)
File -> History

Click on the day when pulseaudio was removed and review what else was removed.
Click on the day when pulseaudio was installed again and review what was installed in addition.

So when removing pulseaudio it removed also:
indicator-sound
libcanberra-sound
ubuntu-desktop
and others.

Make sure you reinstall above packages.
(The ubuntu-desktop is just a metapackage but it will make apt to get missing packages.)

And maybe your sound then works again.
You can also install gnome-alsamixer a GUI which allows you to view all sound cards and it's settings.

Alex Riggle (mousethief) said : #20

Thank you for all your help. Right now I really don't have the sort of time I obviously would need to put into this to get it up and running; hopefully at some later date I will be able to revisit it and give it the attention it needs.

Thanks,
Alex